Can not boot after installation

Hello all.
I successfully installed clear linux on my Asus UX31E. However after restart i have message “Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key”.
I can not start EFI shell and that’s why i can not try this Finished installation, but doesn`t show up in BIOS
I tried this https://docs.01.org/clearlinux/latest/guides/maintenance/fix-broken-install.html but nothing.

Do you have a boot partition and is it flagged as boot and EFI System Partition? Does it contain the necessary files?

Also, look in your BIOS settings. Maybe you need to turn off Secure Boot?

I installed according to this manual with “Destructive Installation” https://docs.01.org/clearlinux/latest/get-started/bare-metal-install-desktop.html. In this case the installer is making automatically boot partition. How can i understand that this partition is marked as boot partition?
I turned off all security settings in my BIOS

I had the same issue with Dell Inspiron 13-5378.
I created the EFI entry manually in the BIOS.

I think it’s something that should be solved by ClearLinux, but in the meantime, you can review your laptop’s bios manual in order to know how to add an EFI entry by hand.

@krokozel, which method did you use to create the bootable USB device?
Also, in the UEFI setup, make sure that legacy boot is disabled and you can see your destination drive.

@rAngeles, not sure I know what you mean when you say you had to manually create an EFI entry manually.

Well, I think I’m not an UEFI expert… but I think the BIOS should be able to detect and mount the EFI partition automatically, and be able to select the .efi bootloader.

In my case, it seems the BIOS was unable to locate the ClearLinux.efi file. Then my BIOS gave me the option to add an “EFI Entry”, which means I can “tell” the BIOS where to locate the .efi file in the EFI partition in order to boot ClearLinux…
This video shows something similar to what I did:

@rAngeles, cool, I’ve never it seen that before where you had to add the EFI shell to the boot menu, it normally should default to the shell if it can’t find a bootable device. I’ll look into this a little deeper tomorrow. Have either of you updated your EFI firmware to the latest available for your systems?