Installation fails

When trying to install Clear Linux on an Intel atom z3735f i got an error saying " failed to find installer media " .
I’m using uefi boot method with grub.cfg usage here

On some motherboard you can choose whether to boot from a device in UEFI mode or in Legacy mode. Would you open the boot menu manually and verify that you boot in UEFI mode?

I can’t see option for changing boot method . I’m thinking it uses uefi method

More likely, you have a USB device, or SD card, with the installer, that is confusing the installer.

What device is this? What medium (usb stick, sd card, other?) did you put the installer on?

Can you shell out on ctrl-alt-f3 and get a root shell? Run lsblk?

I tried installing clear Linux by removing memory card but still the problem exists .
I can’t get into a terminal by pressing the key combination after the error screen .

Try to press the key before you see the error.

I got a root shell not by pressing the key combination but from the boot menu . But I failed to execute lsblk on the shell

Try updating your BIOS firmware first.

1 Like

That’s an EFI Shell, not a root shell.

Can’t get into a root shell before the error appears using key combination .


I’m not sure which of the listed devices is clearlinux. You can try something like:

cd EFI

Try this for fs0: and fs1:, and for blk0: and blk1: and blk2:. One of these may just work.

Alternatively, try again to find the boot menu and looking for an UEFI USB entry.

I have seen a similar problem - my desktop with CL has started to fail, so I have backed up my data and have decided to reinstall CL. Couple notes:

  1. I have installed CL in a past (about half year ago) on the very same HW from Live USB - no problems;
  2. BIOS firmware is updated and same as in previous install;
  3. After recent CL update (on SSD) - I have boot failure after restart (with similar message on not finding boot media). Not sure on reasons (HW failure or CL failure) I have decided to re-install.

I have created live USB, tried to boot - and … same errors as on the top of this thread. So, I tried alternatives - use the same USB flash, the same application for writing bootable USB from ISO file, just different OS/ISO. The alternative OS were successfully booted from USB, successfully installed on SSD, and successfully running my system.

So, it seems like it is some bootloader failure for particular CL version.

Try a old version of ISO.

I noticed that using unetbootin makes the USB install fail at this same point.

When I switched to dd to copy the iso over it worked perfectly, on the 2 different iso I tried, since at that point had downloaded the most current, then the oldest that didn’t show up as a .xz file.

Try etcher, it’s cross-platform and is faster than dd.

Also, I’ve had good luck with rufus (3.8).

Yeah, both Rufus and Etcher work better than dd.

On macOS, it’s not GNU dd but BSD dd so there are minute differences. Like the uppercase vs. lowercase when specifying the buffer size.

Also, I remember dd failed when the buffer size is too small for the target device.

These problems are automatically worked out by Rufus and Etcher.