Can't find / or launch Tomcat

Sorry this seems like such a dumb question. I’ve installed java and apache-tomcat via:
swupd bundle-add java11-basic
swupd bundle-add apache-tomcat

Both completed successfully

I’ve found the java installation path, can’t find anything about tomcat. I’ve tried searching for apache-tomcat.service or tomcat, looked in /usr tried launching via systemctl start tomcat / systemctl start apache-tomcat

Can’t seem to find any information on this at all…

I do not use Tomcat, but read this News


I’ve just copied my previous tomcat over with custom tomcat.service file since tomcat is not OS dependent and pointed to the Java 11 to run it.

Only problem I’m having now is systemctl can’t find my tomcat.service file. I’ve placed it in /usr/lib/systemd/system/multi-user… and /etc/systemd/…

Ran systemctl daemon-reload. Says the file is not there. I’m going to resort to just running right from the JVM I guess. I can’t find documentation on how this works.Very frustrating.

Place it in /etc/systemd/system/ instead.


That worked. Thank you. Have no idea why i have to do that. I’ve read the docs back and forth

Anyways thanks very much

1 Like

The key part of man systemd.unit has this section at the top:

   System Unit Search Path

The paths listed underneath are all used. Of all of them listed, the ones under /run are transient and you don’t want. There are specialized ones with .attached and .control that you also want to avoid. What remains is /etc/systemd/system. Note that /etc/systemd is not listed. That path is only valid for config files that are NOT units, like journald.conf and timesyncd.conf.

1 Like