Daylight Savings in GNOME 3.38 not displaying correctly in GNOME panel

To start, I have seen this topic, and am aware that it appears to be a bug with GNOME as shown here.

My question is, how else can we temporarily fix this aside from disabling auto time, date, and zone updates and manually changing the time? This would be horribly inconvenient if say someone constantly traveled between time zone boarders for work. I feel like the answer would lie somewhere in dconf editor, but am unsure of where, or even what to look for if said setting even exists.

As a note, I was hoping this would have been fixed with the next GNOME update from this morning, but alas, it was not fixed. Ideas?

No joking, learn to live with UTC.
I memorized the time zone of a couple major cities around the globe and I’m calculating the local time in my mind all the time

Canonical and Fedora both have their own (independent) downstream patches, maybe you could go browse their source code and see what they did to fix it.