Desktop Gnome live USB look?

How can I make my Clear Linux installation desktop look like the desktop that is used when I run it from a live USB drive. Is there a particular Gnome extension/Theme that is used on the live USB Desktop (i.e. left side dock, Flat icons? ) Thanks for your help.

There is no difference between the installed desktop? I mean, there shouldn’t be. If you have an older intallation, it may require some resetting of configuration though.

I have the newest version. but what I did was install the server version (Bare metal), and then added the Gnome desktop bundle. My desktop has the menu bar at the top with “Applications” and “Places” menu items. Perhaps I need to download another bundle? Just not sure which one.

It sounds like for some reason your system is using the GNOME metacity theme (GNOME Flashback).
How are you starting the desktop? Do you have a custom ~/.xinitrc file?

The desktop-autostart bundle will automatically start the desktop with the clr settings.

I didn’t create a custom “~/.xinitrc file”… but now I can’t check because I borked my install :stuck_out_tongue_winking_eye: Now when it boots up it has an issue with the “VCPU” so it jumps directly to blank screen with frozen cursor at the top :roll_eyes:

Does Clear Linux have a recovery mode key combo at boot(similar to ubuntu) where I can boot into a root shell using the shift key and make change to the configs like setting “nomodeset” or repair or remove video drivers in order to troubleshoot?
Thanks in advance for your help.

During booting up, hold space to show the systemd-boot login menu. At the kernel you want to use, press e to edit the command line option.

You can add in the end to boot into rescue target.

Thanks I will give that a try.

Ugh! I may have to do a reinstall. My install is dual booting on an old Macbook pro, so that is complicating things. If I hold the spacebar when I try to boot it doesn’t seem to have any effect. It just throws the same Radeon VCPU error about 10 times then the screen flickers and it goes to a frozen black screen with the cursor in the upper left. I can boot to the Mac OS and use diskutilities to mount the partition that CL is on so I can access the file system. I’m just not sure which files I need to go to in that filesystem to edit in order to at least bring up a bare bones root shell so I can try to fix what I suspect is an discrete graphic card issue. Ultimately I’d Like CL to ignore the AMD Radeon discrete graphic card(known issue for this model year Mac) and use the onboard intel GPU instead I can then try and fix it so it will boot to the desktop. I work around the graphic card issue when booting into the mac os by overwriting some nvram settings in single user mode prior to boot.

You can boot with live CD and do the editing.

Thanks, I’ll give that shot. Would you be able to tell me what is the location and file name where CL stores the boot command line it uses at start up so I can add the “”?
Thanks again for your patience and help.

/etc/kernel/cmdline.d/ is the drop-in directory where you can have conf files with boot parameters.

But note that you need to modify the boot parameters for your main system, not the live CD.

Suppose in your live CD system you mounted the partition where your main system is located in at ~/foo. Here ~ is the home directory for the user of the clear live cd.

Then you need to go to ~/foo/etc/kernel/cmdline.d.

Thanks again @doct0rHu. That makes things much clearer for me to proceed. :slight_smile:

Ok, I did a quick reinstall of CLR server and I am back to a working command line.
I then did a “bundle-add desktop”. I would like to continue boot into command line and not auto boot to desktop. Now that I have the desktop bundle installed how can I boot to GNOME desktop(what command do I need to type to launch?)

Say you’re in the tyy and logged in, then various display managers could be started manually/automatically via systemctl as its services.

As for gnome by default the display manager, or more strictly speaking login manager, is gdm and so you can run systemctl start gdm. And there’re other display managers available in swupd, such as sddm and lightdm.

But note that display manager is not the same as desktop environment. So you can have gdm, but instead of starting gnome, you can start i3, awesome, or other desktop environment. They are available in swupd and any installed desktop environment will have a corresponding session file in /usr/share/xsessions.

So to sum up, the graphical display manager could be started by systemctl start XXX, and desktop environments are located in /usr/share/xsessions and you can choose a desired one when logging in.

Great explanation… thank you again. I will play with this and see if I can get it working. :+1::+1::+1: