Disable Nvidia GPU


I have an MSI GL63 8RE laptop with Intel core i7 8750H and NVIDIA GTX 1060 GPU. I want to turn off the NVIDIA GPU permanently while using Clear Linux. The battery of the laptop is getting drained quickly since I can’t switch to Intel’s GPU. I am also using Ubuntu and there is no such problem.

By the way, the kernel version is 5.4.18-902.native. I tried installing drivers for the GPU by following the official tutorial (https://docs.01.org/clearlinux/latest/tutorials/nvidia.html) and ended up with “Oh no! Something has gone wrong” GNOME crash screen. Later, I uninstalled the drivers(NVIDIA-Linux-x86_64-440.59.run)

Now, GNOME is OK but I still can’t turn off GTX 1060. Please help me to turn off GTX 1060.

Thanks in advance.

Check your system’s EFI/BIOS. Ideally, there will be a setting that will let you disable the discrete GPU from there.

If not, my understanding is it gets more complicated requiring the special software/kernel modules. You can search the forums for “optimus”.

@puneetse Thanks for the reply. Unfortunately my UEFI doesn’t have the option to disable the GPU. As advised, I have searched forums for configuring optimus. Steps mentioned in posts are difficult and also there is no guarantee that the GPU will be turned off. The official tutorial doesn’t mention anything about Nvidia optimus.

Kindly suggest me any article to disable GTX 1060 in Clear Linux if possible.

You’re right - all the Linux solutions appear complicated and like you said, it is not turning off the device completely. The tools mentioned in there and the ArchLinux wiki (bbswitch and acpi_call) are not packaged in Clear Linux so you will have to build them manually. You’ll need DKMS for which we have documentation here: https://docs.01.org/clearlinux/latest/guides/kernel/kernel-modules-dkms.html

You can try the solutions in the post ere: https://www.reddit.com/r/archlinux/comments/e7d7ea/disable_nvidia_gpu_i_finally_did_it/ .

I don’t have one of these systems first hand so I can’t help test, unfortunately.

@puneetse Thanks for replying. Currently I am out of town. Once I am home, I will try the steps mentioned in the above articles and inform you about the progress.