Does audio quality in clear linux is better than other distros of linux?

Currently I’m in Debian 10 and I almost surfed most known distros and also tweaked my /etc/pulse/daemon.conf for several times and several modes and tried every latest kernel but nothing seemed worked.
Does clear linux has any edge over audio performance since my laptop audio card is intel’s one.

My pulseaudio config file

This file is part of PulseAudio.

PulseAudio is free software; you can redistribute it and/or modify

it under the terms of the GNU Lesser General Public License as published by

the Free Software Foundation; either version 2 of the License, or

(at your option) any later version.

PulseAudio is distributed in the hope that it will be useful, but

WITHOUT ANY WARRANTY; without even the implied warranty of

MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU

General Public License for more details.

You should have received a copy of the GNU Lesser General Public License

along with PulseAudio; if not, see http://www.gnu.org/licenses/.

Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for

more information. Default values are commented out. Use either ; or # for

commenting.

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; enable-memfd = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
cpu-limit = no

high-priority = yes
nice-level = -15

;realtime-scheduling = yes
;realtime-priority = 9
;realtime-scheduling = yes

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

resample-method = soxr-vhq
avoid-resampling = false
enable-remixing = yes
remixing-use-all-sink-channels = yes
enable-lfe-remixing = no
; lfe-crossover-freq = 0

; flat-volumes = yes

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
rlimit-rtprio = 9
; rlimit-rttime = 200000

default-sample-format = float32le
default-sample-rate = 96000
alternate-sample-rate = 48000
default-sample-channels = 2
default-channel-map = front-left,front-right

default-fragments = 4
default-fragment-size-msec = 125

enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 8000
deferred-volume-extra-delay-usec = 0

I’m not aware of any specific tweaks made for audio.

Chris

I’m just talking about the resample-method and sample-rate do they have any measurable effects on audio quality. I just think the level are improvised but the major drawback is that the audio breaks continuously.
It generates some kind of noise that makes me to feel difficult on wearing headphones, mine is Oneplus wireless Z, I haven’t felt any of this when I used windows 10.

Can I adopt the audio driver from windows to linux (I mean by some simple looking over the code)??

You can also tweak PulseAudio but may of the files needed are in different locations than other distros.

I have the same issue with a NUC5CYPH (driver=snd_hda_intel): the audio break .

In Fedora I put in /etc/modprobe.d/dist-alsa.conf :
options snd-hda-intel power_save=0 power_save_controller=N

I don’t know where put this in Clear Linux

same place …

1 Like

does nothing in the same place: /etc/modprobe.d

Not likely. Going to take some work. It’s probably not worth getting into (re-)writing drivers just to get better support for your headphones unless you just enjoy it and have lots of time or are doing it as learning experience.

I don’t understand. the module is in the kernel:

what don’t you understand?

From the documentation

You can specify which options to use with individual modules, by using configuration files under the /etc/modprobe.d directory.

/etc/modprobe.d is the correct directory

I did this as with Fedora: still the same issue although it is corrected with Fedora.

This directory worked for me for other purposes.