Can not get Intel HDA sound to work

Hello, I am brand new to clearlinux and using brand new intel hardware (intel i7 NUC 10th gen comet lake) and am having a difficult time getting my sound card to work.

I have VLC and ffmpeg “ffplay” both working playing music and video files (VLC doesn’t play videos that ffplay can play and ffplay has a slow stuttering effect when playing 4k hevc videos but 1440p 60fps play clear and perfectly)… no sound for either vlc or ffplay.

Also no sound at all for Firefox as well as problems with videos not playing on reddit, but everything works properly with Youtube playing 4k 60fps 2160p videos perfectly (with no sound but crystal clear picture).

And no sound for gnome->settings->sound speaker test, and I get a strange “pop” from the speakers when messing with the settings of pavucontrol… also when I play a file like the gnome speaker test the pavucontrol looks like it has sound playing but no actual sound is palyed.

I have been reading posts on this forum as well as trying different things from the Arch wiki and Gentoo wiki as well as some things from some Ubuntu wikis.

My soundcards are always shown when using commands like lspci and other commands.

Using the command ‘pacmd list-sink-inputs’ while playing VLC and ffplay I am able to see both applications sinked and recognized with name and bin, as well as 100% volume and not muted… but I can not get any sound.

When messing around with pavucontrol and alsamixer, as well as gnome sound I can get a “pop” from my speakers that are plugged into the headphone jack of my intelNUC10.

I tried to use hdajackretask and did not know what to do. Any settings that I tried to apply caused an error:
tee: /sys/class/sound/hwCOD2/reconfig:Device or resource busy

I tried adding an /etc/modprobe.d directory with these files in it:

/etc/modprobe.d/blacklist.conf with:
blacklist snd_soc_skl

and a /etc/modprobe.d/alsa.conf with:
options snd-hda-intel model=headset-mic

and a /etc/modprobe.d/alsa-base.conf with:
options snd-hda-intel model=auto
options snd-hda-intel dmic_detect=0

No luck so far.

I thought of trying to uninstall pulseaudio but they are both part of the desktop bundles. I also added some gsteamer bundles and other sound related bundles to get some commnad line tools.

I’m sure there is an easy fix to this that I am unaware of.

Any help will be appreciated. Thank you.

I just checked out my intel hda problems on a manjaro live install environment and had the same issues. Then tried a NixOS live install and also had no sound working.

So I’m pretty sure this is a new 10th gen comet lake issue that will be fixed soon… so I will just hang out and wait patiently since everything else is working nicely.

If anybody has any ideas for a workaround I’ll give it a try.

Also, every time I boot into a distro my speakers do a loud “pop” sound. Same thing happened when using the manjaro live environment when I used this command:

sudo rmmod snd-hda-intel -f; sudo modprobe snd-hda-intel

I can’t use that command on clearlinux because “Resource temporarily unavailable”.

Hi, Did you tried Ubuntu 20.04, Kubuntu 20.04 and Pop Os 20.04. All I have tested on the hardware you mentioned and they worked smoothly. No sound issue with speakers and mic. On Manjaro I was able to fix issue but clear linux, I guess still missing alsa latest firmware.

I have not tried another distro other than the live installs of NixOS and Manajaro. I might try Ubuntu just to see if it works. If it does work with Ubuntu then I can just reinstall clearlinux at a latter time (I like how fast and solid this distro feels).

That HP SPECTRE that you have looks like an awesome laptop… with better graphics than my intel NUC10 i7-10710U.