Dropbox misses a dependency

Hello everyone! (Newbie alert)

I’ve recently installed CL and tried to build dropbox from the source, more specifically “nautilus-dropbox-2020.03.04”
When I tried to built, terminal notified me that “libnautilus-extension”, which I tried to search on the software page but I coudln’t find anything.
It is worth noting that terminal also said that

No package 'libnautilus-extension' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables NAUTILUS_CFLAGS
and NAUTILUS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.

After that, the closest thing that I found was “devpkg-nautilus”, so I installed and attempted to install dropbox again. It compiled but it was a failed installation in which it kept complaining about the “missing depdency”

How do I set those environment variables? Is there any other way to adress this issue?

Build the dependency from source.

That would be the easy solution.
If it weren’t for the fact that, to compile “libnautilus-extension”, you have to recompile nautilus.
I find it really weird that CL developers didn’t include a package that apparently compiles by default.

Anyways, I rebuilt Nautilus from source and Dropbox was finally installed.
As a side note for those who want dropbox natively instead of the flatpak version, you should put “sudo make install” instead of “make install”, otherwise the installation would fail again.

If you have serious difficulty building Dropbox you may get the wrong one.

The one on official website is not maintained anymore. You should build from the GitHub source repo.

In short, there’s no need to recompile Nautilus.

1 Like