No Dropbox icon

Hello,

I installed Dropbox using flatpak:

flatpak install flathub com.dropbox.Client

However upon Dropbox start, there is no icon to configure the Dropbox settings.
The app runs, and downloads everything, but thats not what I need …

Welcome to the forum, André.

Did you install the desktop bundle first ?

sudo swupd bundle-list | grep desktop

sudo swupd bundle-add desktop
1 Like

Thanks :slight_smile: Yes, GNOME desktop is fully installed and running fine.

Password:
Loading required manifests…
Warning: Bundle “desktop” is already installed, skipping it…
1 bundle was already installed

Another questions is if anyone actually got it working at all ?

Welcome to the forums! :grin: I would suggest checking that you have status icons enabled through gnome. I forget the default setting, but I know they have an option to hide them.

1 Like

For tray icons you need topicons plus as a Gnome extension, and you need to install the proprietary Dropbox client. That can be found at their GitHub, which provides Nautilus integration.

Can somebody confirm that they managed to enable the icon?

As I replied before, you need to install the proprietary Dropbox, which comes with Nautilus integration.

Hey doct0rHu. Many thanks for you replay. I tried to follow your steps but still I don’t get a dropbox icon in the top bar. I did the following:

  • I installed TopIcons Plus over the Software center
  • Then I downloaded Dropbox as a 64bit rpm file from https://www.dropbox.com/download?dl=packages/fedora/nautilus-dropbox-2019.02.14-1.fedora.x86_64.rpm
  • I ran rpm -U --nodeps nautilus-dropbox-2019.02.14-1.fedora.x86_64.rpm
  • Then I started Dropbox over the applications menu and followed the instructions, which downloaded some stuff.
  • After rebooting I can see in the files that icons that dropbox is syncing etc. So that works absolutely fine. Also I am getting notifications. Rightclicking on dropbox folders also give me the options to share etc.
  • However, I still can not access any settings for dropbox because the top icon is missing.

What did I miss?

I’m away from my computer and I may not recall correctly. The pop-up menu might be available after you installed KStatusNotifierItem/AppIndicator Support.

If you don’t need that GUI settling, you can use dropbox command in terminal.