Elan Touchopad Gestures do not working

I don’t how I could install drivers for it.

I know that in Arch linux it worked with some package, then the things are quite different here.

Thanks for your help!

Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Logitech Wheel Mouse id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ USB Video Device id=10 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]

This is my xinput list output

you could try this


I’ve not tried it because I’m running Wayland.

I was going to try this too.

are you using gnome?

edit, just to add confusion, I’m wondering if something designed to work with X.Org would work with XWayland.


I think it’s a problem with all recent linux kernel, because only with Ubuntu 16.04 it works. And I need to explain better the issue, 'cause the detailed issue is:

My touchpad is been detected as Logitech PS2, but the real driver and touchpad is named Elantech, so I can’t scroll using 2 fingers what is very awnful.

I search for a solution on systems based on debian and Archlinux as well.

Do you have any suggestion to solving this issue?

Thank you for your attention.

Ah yes that’s a bit more specific. My old HP EliteBook Folio had a Synaptics Forcepad that defaulted to generic PS2 drivers, as no Linux driver exists for it. Was awful, so i stuck to Windows for that machine.

Linux devices drivers are way outside of my experience.

Perhaps the Arch Linux package contains and loads the correct driver.

You could find the source for that package and take a look what it’s doing.

Perhaps you can then extract the driver and load it in to the running kernel.



should give you a better identification of the actual hardware you’ve got.

Searching for my specific hardware on the Arch and Gentoo sites has turned up a few little fixes that google missed.

Just another thought, you could boot up a live version of the Ubuntu 16 that worked and run

sudo lspci -v

and that should tell you what your hardward is in detail and also shows what kernel driver is loaded.