Erlang source files?

Hi all -

Been using Clear Linux for a few months now and really enjoying it. Currently however, I am trying to add an sqlite dependency to my elixir project. To compile the dependency, this requires that some of the erlang source/include files are in my system path. Specifically, I am getting an error that the file “erl_nif.h” can’t be found. I have elixir 1.9.1/OTP 22/erts 10.4 installed on the system via the openstack-common bundle, but I can’t find the necessary library files, if they are even present. I tried following this suggestion, but my /usr/lib64/erlang folder doesn’t contain any header files. I also tried searching around the file system with find via command line and came up short.

At this point, I see two solutions: either I’m missing the location of these files/I need to add some other bundle to get them, or I should try and uninstall erlang/elixir from the openstack-common bundle and manually install it. Thoughts and/or suggestions?


Hi Gus, welcome to the forums.
I’d definitely log this in Github if there are files missing. Either someone can point at a bundle which has them, or we may need to create a -dev bundle which includes them.
In the short term, manually installing should get you up and running.


Hi Chris,

Thanks for the response. I’ll definitely add this as an issue in GitHub. Just to confirm, that would be this repo, correct?


Correct, yes, that’s where we keep all the bugs.

1 Like