Evince - File type PDF document (application/pdf) is not supported

Hey everybody,

I’m not sure what happened, but maybe after any last update I can’t open PDF Files with Document Viewer evince.
It always tells me File type PDF document (application/pdf) is not supported

Any idea what happened and how to fix that?

I’m still able to open my PDF Files by another App like Master PDF Editor. So the PDF File seems to be ok.

I also checked if evince is up-to-date by $ sudo swupd bundle-info desktop-apps
and tried with $ sudo swupd repair. But I’m not able to open PDF Files with Document Viewer evince anymore :confused:

I also tried

sudo swupd bundle-remove evince
sudo swupd bundle-add evince

but its still the same. PDF is not supported :thinking:

I saw that I use also the flatpak version

Thanks for the hint with flatpak version.

I did the following and now its working fine :slight_smile:

$ sudo swupd bundle-remove evince
$ flatpak install flathub org.gnome.Evince
$ flatpak run org.gnome.Evince

Strange that the swupd version is not running :thinking:

1 Like