Failed to build kernel RPM

Building process terminated due to following error:
Total size: 80 M
Total download size: 74 M
Installed size: 253 M
Downloading Packages:

Error: Error downloading packages:
Cannot download Packages/linux-firmware-20180000-105.x86_64.rpm: All mirrors were tried

make: *** […/common/Makefile.common:95: build] Error 30

I tried to build linux-firmware package separately, seems no issues found:
lin@lin-clear ~/workspace/ali-kernel/clearlinux/packages/linux-firmware/results $ ll

total 336592
-rw-rw-r-- 1 lin lin 14341 May 29 08:20 build.log
-rw-r–r-- 1 lin lin 179591164 May 29 08:19 linux-firmware-20180000-105.src.rpm
-rw-r–r-- 2 lin lin 77430960 May 29 08:20 linux-firmware-20180000-105.x86_64.rpm
-rw-r–r-- 2 lin lin 5844 May 29 08:20 linux-firmware-abi-20180000-105.x86_64.rpm
-rw-r–r-- 2 lin lin 62541 May 29 08:20 linux-firmware-doc-20180000-105.x86_64.rpm
-rw-r–r-- 2 lin lin 13784465 May 29 08:20 linux-firmware-extras-20180000-105.x86_64.rpm
-rw-r–r-- 2 lin lin 73517779 May 29 08:20 linux-firmware-wifi-20180000-105.x86_64.rpm
-rw-rw-r-- 1 lin lin 102616 May 29 08:20 root.log
-rw-rw-r-- 1 lin lin 958 May 29 08:19 srpm-build.log
-rw-rw-r-- 1 lin lin 120669 May 29 08:19 srpm-root.log
-rw-rw-r-- 1 lin lin 1218 May 29 08:20 state.log

Hey @Lin are you still experiencing this if you try again? I’m wondering if it was a temporary network issue.
(do a make proper to start clean)

If you continue to see issues, try looking in the results/root.log.

Looks like a Network issue

I noticed you cross posted this on GitHub. I’m putting the link here for reference and updates. https://github.com/clearlinux/distribution/issues/815.

Yes, this should be an networking issue since I keep encountering the failure of downloading for different packages and it could be addressed by using different proxy, i also tried “make proper” and it’s workable sometimes.

BTW, i’m trying to build a custom kernel bundle like “linux oracle”, i’m using mixin and failed during “mixin build” due to cannot find the file with name “Mainfest.Mom”, also i just found that this tool is going to be deprecated soon, could you give some suggestions on how to build a custom kernel bundle?

Thanks!
/L

As for the network issue, could that be related to the GFW?

What is your network environment?

GFW is always an issue has to be considered… as for my environment, i can access external networking but proxy has to be used sometimes.

As for GFW, you may build a shadowsocks server, then try again.

Try the process here: https://clearlinux.org/documentation/clear-linux/guides/maintenance/kernel-development