Failed to run IGT tool

I am trying to run IGT tool on intel KBL NUC but its failed with below error

shiva@shiva /usr/libexec/igt-gpu-tools $ sudo ./kms_rotation_crc
IGT-Version: 1.23-NO-GIT (x86_64) (Linux: 5.0.9-741.native x86_64)
Test requirement not met in function igt_device_set_master, file …/lib/igt_device.c:52:
Test requirement: __igt_device_set_master(fd) == 0
Can’t become DRM master, please check if no other DRM client is running.
Subtest primary-rotation-90: SKIP
Subtest primary-rotation-180: SKIP
Subtest primary-rotation-270: SKIP
Subtest sprite-rotation-90: SKIP
Subtest sprite-rotation-180: SKIP
Subtest sprite-rotation-270: SKIP
Subtest cursor-rotation-180: SKIP
Subtest sprite-rotation-90-pos-100-0: SKIP
Subtest bad-pixel-format: SKIP
Subtest bad-tiling: SKIP
Subtest primary-x-tiled-reflect-x-0: SKIP
Subtest primary-x-tiled-reflect-x-180: SKIP
Subtest primary-y-tiled-reflect-x-0: SKIP
Subtest primary-y-tiled-reflect-x-90: SKIP
Subtest primary-y-tiled-reflect-x-180: SKIP
Subtest primary-y-tiled-reflect-x-270: SKIP
Subtest primary-yf-tiled-reflect-x-0: SKIP
Subtest primary-yf-tiled-reflect-x-90: SKIP
Subtest primary-yf-tiled-reflect-x-180: SKIP
Subtest primary-yf-tiled-reflect-x-270: SKIP
Subtest exhaust-fences: SKIP

before running i had executed below steps
systemctl | grep -i getty

systemctl | grep -i gdm

sudo systemctl stop serial-getty@ttyS0.service

sudo systemctl disable serial-getty@ttyS0.service

sudo systemctl stop

sudo systemctl stop gdm

sudo systemctl stop gdm.service

sudo systemctl stop gdm.path

sudo systemctl disable gdm.service

sudo systemctl disable gdm.path

How can i check who is holding DRM master ?


A post was merged into an existing topic: Running IGT tool