Gnome Xorg not booting after update

I preformed a swupd update and after the update I’m not able to login to gnome Xorg but I can login to Wayland.
The login screen asks for password and after entering the password again shows the login page.
Xorg Log

I had this issue for awhile. In my case it was as small and simple as a .bashrc error (git prompt script attempting to load unavailable fonts and colors). I guess Wayland was able to start despite the error but gnome on xorg could not. Took me quite awhile to figure it out while just using Wayland. It wasn’t until firefox quit working on Wayland and I was forced to use gnome on xorg that I finally took the time to debug it properly.

I don’t have any git commands to pull fonts in my .bashrc.
The only error I could find in Xorg log is

[ 1243.686] (II) LoadModule: “intel”
[ 1243.688] (WW) Warning, couldn’t open module intel
[ 1243.688] (EE) Failed to load module “intel” (module does not exist, 0)

Looking around in forum suggest that intel driver is not available hence the error.
But the strange thing is I don’t have intel driver mentioned in Xorg.config. I didn’t even change
any config and using whatever was shipped with Clearlinux.

Any pointers where should I look ?

$ ll /usr/share/X11/xorg.conf.d/
total 16
-rw-r–r-- 1 root root 92 Oct 12 2019 10-amdgpu.conf
-rw-r–r-- 1 root root 1350 Jan 14 22:03 10-quirks.conf
-rw-r–r-- 1 root root 92 Mar 23 2019 10-radeon.conf
-rw-r–r-- 1 root root 1429 Sep 11 2019 80-libinput.conf

Are you using any gnome shell extensions?
And could you try logging with Ctrl+Alt+F3 and typing

systemctl restart gdm

And then see if it works?

Ctrl+Alt+F3 din’t work.
I’m using some gnome extensions but I think those are causing the trouble.

Do you have idea regarding the Intel driver that Xorg log is referring to being missing ?

Ctrl+Alt+F3 should work. Needs to be left alt. I’m not sure about the driver. What platform are you on?

You can replace F3 with F4, F5, etc…

Sorry I meant the keys work but its didn’t solve the problem of logging into Gnome Xorg.

These key bindings are not supposed to bring you into GDM, but let you log in via TTY, from which you can remove your gnome extensions.

Ohh… but I can login to Gnome Wayland session. And I removed all user installed extensions. Still not able to log into Gnome Xorg session via GDM login. I think my issue is different than black login screen which other are facing.

Definitely a different issue (the blank screen issue is now resolved) and most like a client configuration issue.

The reason I asked you to try TTY and restart gdm is because if it worked after a late restart of gdm it would help narrow down our issue.

It’s impossible to give any tips for driver or module errors without knowing your platform. Do you have a modified .bashrc or anything under /etc/profile.d?

If you ssh into your machine from another (using your username) does your shell report any profile errors at login?

If you login to Wayland and graphically create a brand new user

right click in desktop >settings>search for users>users>unlock (enter passwd)>add user (set easy password  now)

Is the new user able to login to Gnome on X?

Not that much modified.

/etc/profile

if [[ $UID -ge 1000 && -d /opt/3rd-party/bundles/greginator/usr/lib64 && -z $(echo $LD_LIBRARY_PATH | grep -o /opt/3rd-party/bundles/greginator/usr/lib64) ]]
then
    export LD_LIBRARY_PATH="/opt/3rd-party/bundles/greginator/usr/lib64:/opt/3rd-party/bundles/greginator/usr/lib32:${LD_LIBRARY_PATH}"
fi

.bashrc

cloe@suclear~ $ cat .bashrc 
# Use global profile when available
if [ -f /usr/share/defaults/etc/profile ]; then
	. /usr/share/defaults/etc/profile
fi
# allow admin overrides
if [ -f /etc/profile ]; then
	. /etc/profile
fi

# bash_aliases
if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# Show contents of the directory after changing to it
function cd () {
    builtin cd "$1"
    ls -ACF
}

# pyenv install
export PATH="$HOME/.pyenv/bin:$PATH"
eval "$(pyenv init -)"
eval "$(pyenv virtualenv-init -)"

No error were reported.

No, new user also faced similar issue. Not able to log into Xorg but logged into Wayland.

Thank you for suggesting these. Anything else that I can try to debug ?

It doesn’t look like the issue is in the user space, unless you’ve manually done some system wide x or gnome customization?

What are the results of

sudo swupd diagnose --picky

If that comes back clean, and you’ve made no changes to x or gnome under /etc or /usr/local you may have a bug to report.

After update to 33100 the issue resolved itself.
And I took a look at the Xorg.log. There was no mention of the the Intel module that was earlier showing error. So seems like all is well.

Previously they updated Mesa which caused some issues on some AMD GPU, but they later downgraded that component (temporarily).

What’s you setup? Does your display connect to a AMD GPU or a Intel GPU?

My laptop has intel integrated and amd dedicated graphics. Don’t know which one is doing what.

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device 80c2
	Flags: bus master, fast devsel, latency 0, IRQ 47
	Memory at d2000000 (64-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 7000 [size=64]
	Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915


0d:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] (rev 83)
	Subsystem: Hewlett-Packard Company Device 80c2
	Flags: bus master, fast devsel, latency 0, IRQ 53
	Memory at b0000000 (64-bit, prefetchable) [size=256M]
	Memory at d4000000 (64-bit, non-prefetchable) [size=256K]
	I/O ports at 4000 [size=256]
	Expansion ROM at d4040000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: radeon
	Kernel modules: radeon, amdgpu

Then probably it was AMD issue in the previous OS version caused the problems.

Yeah seems like that only.
You mentioned downgraded temporarily. Does it imply they resolved the bug and already upgraded Mesa ?

They downgraded Mesa for now and will upgrade it when other components are re-compiled.
You can safely enable the auto-update now.

1 Like