How can I launch Chrome in kiosk mode from terminal without notifications?


For professional use, we are running Chrome from the terminal using nohup google-chrome-stable --new-window --app="$URL_0" &>/dev/null & .

Then :
1 ) Chrome displays a login web page with a Citrix URL,
2 ) When logged OK, Chrome downloads the .ica Client,
3 ) BUT Chrome displays notifications in the form of pop-ups warning of possible risks, which cannot be accepted for this type of professional use…

Question :

  • How can I block the appearance of warning pop-ups from the shell ?
  • What should I add to my script ?
  • nohup google-chrome-stable --new-window --app="$URL_0" &>/dev/null &

PS : OK for Chromium if it is simplier

Thanks for your help !

Best Regards,

create / edit config file :

 nano ~/.config/chromium/Default/Preferences
       "browser": {
           "show_home_button": false,
           "check_default_browser": false,
           "incognito": false
       "session": {
           "restore_on_startup": 4,
           "startup_urls": ["https://your-url-here"]
       "url_blacklist": ["*"],
       "devtools": {
           "disabled": true

command line :

nohup chromium-browser --kiosk --disable-pinch --disable-touch-adjustment --disable-touch-drag-drop --disable-touch-editing --disable-touch-selection > /dev/null 2>&1 &

Thanks a lot Businux !
I try it rightaway.

Best Regards,

Thanks works well !
I just had to made some modifications because I need to propose up to 3 portals at the same time …

nohup google-chrome-stable --new-window --app="$URL_0" --disable-pinch --disable-touch-adjustment --disable-touch-drag-drop --disable-touch-editing --disable-touch-selection > /dev/null 2>&1 &

Here is a test with 3 standards URL

1 Like