Hyper-v "Dazed and confused"

when following the guide to install in windows hyper-v I setup a root user and a password and then am given the following output after waiting a while.

[ 299.305809] uhhuh. NMI received for unknown reason 00 on CPU 0.
[ 299.305809] Do you have a strange power saving mode enabled?
[ 299.305809] Dazed and confused, but trying to continue

I am running this on a Asus GL702vm laptop. My laptop is plugged in and not in power savings mode.

Hi Michael, welcome to the forum.

This message appears to be generated by the Linux kernel when it gets an NMI from an unknown source. From googling it doesn’t appear to be uncommon, or particularly serious, but can be very annoying if you’re working in a command line and it happens often.
Are you seeing it happen frequently?

Rgds,
Chris

1 Like

Yes. Every time I start the VM and login and then wait a while. Does the Hyper-v download not have the GUI installed? The only internet where I am is “open” but requires logging in on a browser. Due to MAC filtering it doesn’t appear to be passing my internet connection through to the VM unless there’s a way for me to change the MAC address of the VM to match my windows environment.

1 Like

What you want is effectively a NAT on your Hyper-V switch, so that your connections from your VMs go in/out of your physical network interface without the physical network knowing.

Unfortunately, NAT on Hyper-V is not so sleek to setup because it’s commandline only and requires manual IP address management or setting up your own DHCP server for it. Here’s a link I found that goes over how if you’re interested in going down this route: https://anandthearchitect.com/2018/01/06/windows-10-how-to-setup-nat-network-for-hyper-v-guests/

Be aware that sometimes restricted networks like the one you described prohibit using multiple machines behind a single connection in their TOS.

When you are connected, you can add a GUI by adding the desktop-autostart bundle (swupd bundle-add desktop-autostart) and rebooting.

1 Like