Install takes a LONG time, runs SUPER slow on USB3

Hey guys!

So I’m having this issue with the installer.

I downloaded the LIVE usb iso, that I’ve put on an USB3 key, which worked fine and it booted SUPER quick, everything worked perfectly, even wi-fi, out of the box. I was extremely surprised!

Sadly, the install didn’t go as well.

My other usb3 key is SUPER fast (even faster than the first one, 500mb/sec), and the installation took about 45 minutes. I knew something was wrong, but there were no errors.

Booting it took a WHILE, it loaded very slowly (even the code at the beginning was line by line, super slow), and once loaded it was very slow as well and the wi-fi didn’t show up this time.

Any tip on what could cause the issue? I’m positive that the USB key is fast and i have tested it’s read/write speed before, it should exceed the speed of a 7200RPM HDD EASILY by 2x.

MB MSI a-320m pro vd-plus, Amd ryzen 7 1700, GTX 1070TI, 16GB kingston ddr4 ram


USB drive has high latency and virtually no concurrency. That’s what matters here.

1 Like

Our installer is not an offline installer. You are fetching most of the data over your internet connection to complete the installation. This, combined with slower USB writes, are causing the installer to take much longer than most people expect.