Booting from USB takes forever

Hi everyone, I have been trying to run Clear Linux 41230 and 41210 (both server and desktop) on my Ryzen 7950X with 16GB of RAM and a ASUS B650E-I booting from a USB key, and all log messages are extremely slow (they appear once every few seconds), so that after 30 minutes it barely got to display messages about the filesystem… and I gave up.

For comparison, I ran the ISO in a VM on my Intel MacBook Pro and getting to the same point it was a matter of a few seconds.
And I used the exact same USB key on an Ubuntu install, which again worked flawlessly.

From my research, although not explicitly mentioned, modern AMD CPUs should be supported, right?

Do you have any suggestions on settings (BIOS?) that I could look into?

I’d really love to experience the speed of Clear Linux and be part of the community :slight_smile: Thank you!


Welcome aboard ! :wink:

Of course.

First check your system’s BIOS settings for any USB-related configurations.

If that doesn’t solve the issue, post your output for :

lspci -k
lsusb -v
sudo dmidecode

Hi @Businux , thank you for your answer! Forgot to mention, basically after > 10 minutes, boot has not yet completed , therefore I don’t have a way to run the commands you mentioned.
To give you an idea, it takes 41 seconds to get to:
[41.187258] systemd[1]: systemd 255 running in system mode

and 71 seconds to get to:
systemd[1]: Hostname set to ‹cir-live>.

From that point onwards , it’s just slower and slower, so that after more than 10 minutes we are still at the first systemd messages.

USB settings from mainboard are defaults.
I tried disabling Bluetooth, Aura functionalities, AMD fTPM , but no changes.
I doubt it has to do with USB speed itself, because there should not be much data read from USB drive in these early stages of boot.

I’ll keep digging to see what I find, thanks again for now!

Based on your post you have tried both the server and desktop (GUI login) iso’s. I have an ASUS mother board with an AMD processor and it boots flawlessly from a USB drive/key. I wonder if the EFI capabilities on your ASUS is not set up correctly. Are you able to boot far enough to run dmesg?
Try dmesg -err to see where your boot is failing. You may need to specify your boot order in the Firmware setup. or boot directly from firmware GUI and select the USB where your Clear Linux is.
ASUS may have a firmware upgrade available.

My system hardware setup:
Hardware setup board setup and model number:
“My HostName”
description: Desktop Computer
product: System Product Name (SKU)
vendor: ASUS
version: System Version
serial: System Serial Number
width: 64 bits
capabilities: smbios-3.3.0 dmi-3.3.0 smp vsyscall32
configuration: boot=normal chassis=desktop family=To be filled by O.E.M. sku=SKU uuid=10DA39AF-849F-A42A-D1C5-50EBF67FFBB5
description: Motherboard
product: ROG STRIX B550-F GAMING
physical id: 0
version: Rev X.0x
serial: 211296106803706
slot: Default string
description: BIOS
vendor: American Megatrends Inc.
physical id: 0
version: 2806
date: 10/27/2022
size: 64KiB
capacity: 16MiB
capabilities: pci apm upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer acpi usb biosbootspecification uefi

CPU details:
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Address sizes: 48 bits physical, 48 bits virtual
Byte Order: Little Endian
CPU(s): 32
On-line CPU(s) list: 0-31
Vendor ID: AuthenticAMD
BIOS Vendor ID: Advanced Micro Devices, Inc.
Model name: AMD Ryzen 9 5950X 16-Core Processor
BIOS Model name: AMD Ryzen 9 5950X 16-Core Processor Unknown CPU @ 3.4GHz
BIOS CPU family: 107
CPU family: 25
Model: 33
Thread(s) per core: 2
Core(s) per socket: 16
Socket(s): 1
Stepping: 2
Frequency boost: enabled
CPU(s) scaling MHz: 46%
CPU max MHz: 5083.3979
CPU min MHz: 2200.0000

Thanks all for the feedback!
Just wanted to say I had to give up :confused: and will try again sometime in the future.
The boot process did not go far enough where I could get to any prompt where to type commands.

Maybe just bad luck with some motherboard chips.
In particular , the B650E-I has a “AURA Led Controller” which cannot be turned off popping up in the USB controllers, not sure if that has anything to do with it.

This is the screenshot after few hours of leaving the PC to boot:

Better luck next time, I’ll download a newer release

Same issue on GMKTec G3 minipc. It’s alder lake N100. I thought Clear would work well on it, but as others have noted it won’t even boot the installer.

Googling, seems that the community doesn’t seem very interested in sorting it out. I haven’t seen any suggestions on how to resolve or what could be causing it. Could it be a EFI setting Clear isn’t handling, or does Clear presume the main drive is empty? I see it report the partitions on my main drive. Current have windows and another linux distro. But it gets slower and slower.

Almost 10 minutes in its at "listening on systemd-journald.socket.

Messages appear super quick until…
“failed to unlink mnt”
could that be the issue?

Problematic little chip, had many issues with it.