Unable to boot iso on amd cpu [Solution]

Hi all,

Few days ago i tried to install clearlinux but i ended up with slow loading on boot screen loading every single bit by 30 sec till it stop and waiting for an hour.
I tried older versions i tried even server version with hope maybe terminal at least will work but ended up with same issue.

Apparently this issue is with AMD CPU as my old machine running intel i didn’t had any issues.

But i found a solution maybe its not greatest but so far it works

So everything starts on boot before launch clearlinux on boot menu press on keyboard “E”
on boot options delete

console=ttyS0,115200n8

not sure if everybody have same but everything what is in console must to be deleted including word console itself

After installing os you gonna be stuck with same problem system will slowly boot till it stops.

Restart computer and before it boots in press ESC button till u be greeted with bootloader

Repeating same process and remove console

After that it should boot your system.

Then go to

/usr/lib/kernel/

find a file calls

cmdline-{version of your kernel} and open it ( i used nano )

and remove console

save close and run command

clr-boot-manager update

Reboot machine and it should work.

1 Like

Could you open an issue in this link Issues · clearlinux/distribution · GitHub?
Thanks for your work and time.

Just posted issue on github

What im worring about is in case on update it might revert these changes back, bit headache but hope so this will be fixed in future updates :slight_smile:

1 Like