Issue with updating software

hello, I’m new to clear linux
today I updated vscode from software center but after launching it shows the previous one and asks again for update . I checked the installed version from software center its the new one but seems launching the previous version (tried it for couple of time didn’t work).
I know the simplest solution might be to remove and install it again
but wanted to ask did I forgot something , is there other way ?

Just check again in a day or two. Some times the flatpak updates run a bit behind. On all distros.

You could also try

mkdir ~/rpms
cd ~/rpms

Get the latest rpm here https://code.visualstudio.com/download

Save in ~/rpms

Install package-utils

sudo swupd bundle-add package-utils
sudo rpm -Uvh --nodeps name-of-your-latest.rpm
cd my-project && code .

Note that the vscode rpm is not relocatable, so a swupd repair with the [–picky] option will break it and require a removal and reinstall.

I believe that it is available in a third party bundle.

There is no need to install the RPM release, because there’s an official tarball release and you only need to extract it.

1 Like

I’m a lazy person so I just uninstalled and install, the version got solved but then after working with code I notice the vscode’s terminal doesn’t know node and it was ugly terminal looked like windows cmd. so I tested it in OS’s terminal every thing was fine but it didn’t know code command. I got angry uninstalled it and manually installed it by running

flatpak install flathub com.visualstudio.code

but it was the same not sure if the problem was from OS or flatpak . uninstalled it and installed it with rpm way suggested by inmanturbo and it worked correctly finally.
I’m totally disapointed in software center and flatpak, idk if the problem was OS

Neither. Flatpak apps aren’t native, they are sandboxed and run isolated from the system. That’s why it can’t find and execute your binaries.

As doct0rHu suggested you could also use a tarball. I like to use rpm for certain things because I don’t mind “owning” a package or two, and it gives me more control over managing updates and version control. Also I can use rpm tools for other things inspecting the headers, etc.

Meh, who am I kidding? I like using rpm sometimes because it’s fun.

Besides if I ever get tired of that one I can just firebomb it with swupd :crazy_face:

I wanted to test rpm for future rpm apps to check if it was free bug , otherwise using tarball was easiest solution (like to do it hard way :stuck_out_tongue_closed_eyes:)