Software not updating

I have three updates in “Software” app. I clicked install to install all of them yesterday. The updates are still not installed.

I’ve cancelled and tried to install again. That hasn’t worked either.

Any tips on what may be wrong?

thanks

See if there are any relevant logs using journalctl -xe and/or try launching gnome-software from a terminal with gnome-software --verbose.

If it is sandboxed software (see details), the first time, it take a while (5 minutes) because you download the common softwares used by flatpak. You can, in this case, use flatpak list, flatpak search and flatpak install flathub software_name in a terminal to see what appends. You can also use the system monitor.

Sorry for my poor English

Thanks for all the help

Only warning I could find that may be related is:
“Warning: Failed to get revokefs-fuse socket from system-helper: User flatpak does not exist in password file entry”

Saw the above when I ran “flatpak update” manually.

Running it manually updated all the software just fine and now gnome-software shows all software is up to date.

Seeing the same issue on another CL box I have. Will run “flatpak update” manually on it as well.

This is probably unrelated and reported upstream: https://github.com/flatpak/flatpak/issues/2959

@theflakes FYI - this bug (https://github.com/clearlinux/distribution/issues/901) was resolved in CL version 30020. Try again after updating.