Issues with mounting NFS share

Hi I’m taking clear linux server for a spin in a virtual machine.

The problem I’m having is with mounting nfs shares.

I installed nfs-utils via
sudo swupd bundle-add nfs-utils

When I try to mount a nfs share I get the following message (screenshot).


If I then type rpcinfo and then the same mount command again it mounts the share. As a sidenote if I type rpcinfo before issuing the mount command I get the following error:

rpcinfo: can't contact rpcbind: RPC: Remote system error - No such file or directory

I have also added this mount to the /etc/fstab and it fails to mount during startup.

I guess the end result is I want to be able to setup a nfs share mount on startup. Everything else seems to be working great.

I figured out the issue was the rpcbind.service wasn’t being started.

sudo systemctl enable rpcbind.service 

fixes the issue. The second part of it not loading in the fstab probably had to do with my original fstab entry. I found an entry online that worked. Below is a sample fstab entry to allow the mounting of the nfs share to work.

hostip:/share /mnt/mountname nfs noauto,x-systemd.automount,noatime,tcp 0 0

1 Like

I followed the steps in the first post but the successful fstab entry for me is:

//nas/folder  /folder cifs  guest,uid=1000  0 0

In my case, I have one of those network attached storage boxes with 4 drives in it. This is the identical fstab entry I had used when this server was running ubuntu.

nas is the windows share name of that device but also is in /etc/hosts