KeePassXC Dark Mode / Theme

Hi there,

I’m using the swupd bundle keepassxc and it’s working fine. But I would like it to use the same theme as all other Applications or at least a dark mode.

Moreover, I’ve installed the swupd bundle qt5ct to be able to configure style of those qt apps.
When I open qt5ct it always tells me “The QT_QPA_PLATFORMTHEME environment variable is not set (required value: qt5ct)

So I set that env temporary by
export QT_QPA_PLATFORM=wayland export QT_QPA_PLATFORMTHEME=qt5ct

After that echo won’t be empty anymore, but only until next relogin/ reboot:

Now I’ve configured dark color scheme in qt5ct app and my favorite font.
When I launch keepassxc by terminal now, I will see a dark theme and my selected font. It’s not equal to all other gtk3 apps, but its dark :smile:
$ keepassxc

But it is only working when I launch keepassxc by terminal.

  • How can I configure environment variables to avoid “The QT_QPA_PLATFORMTHEME environment variable is not set (required value: qt5ct)”?
  • Is there a way to get more Themes for Qt5 Settings App? Right now I only could choose between Windows and Fusion
  • Is it possible to launch keepassxc by gnome app menu with Qt5 configured color scheme etc.?

Thanks a lot!

Greetings Marcel

Something like the following in your *.desktop file should work:

Exec=env QT_QPA_PLATFORM=wayland QT_QPA_PLATFORMTHEME=qt5ct /path/to/keepassxc

That’s working fine. Thank you :smiley:

Now I just need to know how to install further Themes/ Color Scheme for Qt5 :thinking: I guess they are called QTCurvce. So I will try to find one that’s matching my Gnome Theme :smile: