Kernel-lts and clr-boot-manager

Hi there,

while trying to get my NUC up and running again I wondered how I could update the boot menu to include different kernels.

Even after adding the kernel-lts bundle and running clr-boot-manager set-kernel and update manually I still have only one entry for the native kernel.

The loader/loader.conf value does show the lts kernel but it seems that this value is ignored.

So, how do I get a list of installed kernels into my boot menu list?

If you want to see the installed kernels use clr-boot-manager list-kernels. You can set the default kernel by using clr-boot-manager set-kernel

If you want to see the list of kernel available, please modify the bootloader time out in clr-boot-manager set-timeout 20.


thank you for the quick response.
I did all that and it worked on at least one of my other machines.

But on my NUC10i7FNK there is just one entry saying “Clear Linux OS”, there is no kernel name/version shown at all. set-timeout values are ignored and set kernel values in the loader.conf do not work either.

I already tried CBM_DEBUG=1 clr-boot-manager update but there were not errors.

I think the developers acknowledge the issue in 33700 build! Hope fix will be issued soon!

It’s possible your /boot partition is not actually being updated. Try the steps here to make sure:

I had this issue recently and it fixed it.

1 Like

Thanks @puneetse I will mark this as the solution.