Logitech G27 Wheel - F1 2017 - Unrecognized

Hi every one, I am Julio from Corrientes-Argentina.
I am very happy with the operation of this operating system, and although I am a novice user, I decided to install it for my daily desktop machine.

I have the following problem: I have installed Steam from flatpack, downloaded and installed the Codemaster F1 2017 game but I cannot get it to recognize my logitech G27 steering wheel. I have read the game FAQs and followed a possible solution to the problem but it did not fix it. It consisted of copying a .rules file in the /etc/udev/rules.d/ directory and then run the following command:

                   sudo udevadm control --reload-rules && sudo udevadm trigger

The text of that .rules file in regards to my wheel is as follows:

Match kernel name of device, rather than ATTRS{idProduct} and ATTRS{idVendor}

so we can access the range file and leds directory. Set rw access to these

files for everyone.

Avoid blanket matching all Logitech devices, as that causes issues with mice,

keyboards, and other non-wheel devices.

Logitech G27 Driving Force Racing Wheel

SUBSYSTEMS==“hid”, KERNELS==“0003:046D:C29B.???”, DRIVERS==“logitech”, RUN+="/bin/sh -c ‘cd %S%p/…/…/…/; chmod 666 alternate_modes combine_pedals range gain autocenter spring_level damper_level friction_level ffb_leds peak_ffb_level leds//brightness; chmod 777 leds/ leds/’"

For other distributions, copying this file written by Feral in /etc/udev/rules.d/ solved the problem but not in ClearLinux. I don’t know if I should edit it with any data from the operating system or if it’s a driver problem.
I have also installed ltwheelconf and jstest-gtk and it detects the steering wheel with all its pedal and button functions but when I run the game I get the following message
“F1 2017 does not have the permissions to access all the functions of the connected steering wheel”.
I hope someone can help me. From already thank you very much.

Did you reboot after installing the udev file in place?

Thank you very much for your prompt response

I left the .rules file in the /etc/udev/rules.d/ directory even though it didn’t work. And if I have restarted the machine on several occasions and with the steering wheel installed. Also copy the .rules file to the /usr/lib/udev/rules.d directory and /usr/local/lib/udev/rules.d but the rule never worked. I read those directories from the udev command help.

Lsusb command output: Bus 009 Device 018: ID 046d:c29b Logitech, Inc. G27 Racing Wheel