LUKS password prompted twice on boot

Hello,

I’m trying to figure out a way to enter my encryption password only once on boot. On boot I first get prompted for my SSD device password:

Please enter passphrase for disk HP SSD EX920 1TB (luks-yyy)!

Then for:

Please enter passphrase for disk SolusCrypto on /!

I’ve configured /loader/entries/Solus-current-5.2.2 as such:

title Solus 4.0 Fortitude
linux /EFI/com.solus-project/kernel-com.solus-project.current.5.2.2-122
initrd /EFI/com.solus-project/initrd-com.solus-project.current.5.2.2-122
options root=UUID=xxx rd.luks.uuid=yyy quiet loglevel=3 splash 
systemd.show_status=false rw radeon.si_support=0 radeon.cik_support=0 
amdgpu.si_support=1 amdgpu.cik_support=1

I think it has something to do with how rd.luks.uuid is configured.

/etc/crypttab is configured as such:

SolusCrypto UUID=yyy luks

/etc/fstab is configured as such:

none        /proc        proc    nosuid,noexec  0 0
none        /dev/shm     tmpfs   defaults	0 0
/dev/mapper/SolusCrypto /   ext4    rw,relatime,errors=remount-ro   0   1

Any advice? I know this is on Solus, but as I understand it both Clear Linux and Solus uses clr-boot-manager

Thank you!

It might be better if you can open an issue in clearlinux/clr-boot-manager GitHub repository.

Right, clear-boot-manager issues unrelated to clearlinux need to be filed on github, please.

Looks like you are opening your encrypted partition twice.

clr-boot-manager will open the partition from “root=UUID=xxx rd.luks.uuid=yyy

to verify, look who many devices you have at

$ ls -l /dev/mapper/

To be clear, remove /etc/crypttab file and root mount point from /etc/fstab.

1 Like

Thank you Miguel! That was it. I’ve also changed rd.luks.uuid=yyy to rd.luks.name=yyy=SolusCrypto.

The weird thing is when I run clr-boot-manager update it reverts back to rd.luks.uuid.

I think this might be related to this. I also get the same error when running clr-boot-manager list-kernels.

Thanks for the pointers, I’ll post this on the project’s issue page.

1 Like