Made a misstake, help with uninstallation

Below is a compilation of installed programs on ClearLinux.
Unfortunately some .rpm installations doesn’t work, and I lack the knowledge to uninstall these. Plus I’ve made a mistake when it comes to updating a Flatpack.
GNU’s image manipulation program (Gimp)
It turned out that there was an update available in the program when I opened this. I opened the link to download it, and installed according to the command below.
Which I apparently shouldn’t have done, and instead awaited this update via ClearLinux software.
So now I’m sitting with two installs of this one.
Can any kind soul explain to me how to uninstall these. I checked under swupd --help, but nothing applicable was there.
I ran the command / subcommand swupd bundle-list, but none of these programs are found there.
CloudBerryBackup is below computer - opt (as well as Chrome and Sophos)
MegaSync is below usr - bin, - usr - share
Manuscript is below usr - bin, - usr - share
Gimp is below usr -bin

flatpack install https: // / repo / appstream / org.gimp.GIMP.flatpakref

Custom installed programs on ClearLinux


FreeFileSync, works - backup (full format files)
Wart, works - backup
Dry browser, works - browser


Tutanota, works - Email (private)
Pcloud, works - document backup, evaluation
Zettlr, works - intended replacement for Scrivener


Chrome, works - browser, use of Syncplicity browser extensions
Tresorit, works - backup of documents, evaluation
Sophos, works - antivirus
Mail Run, Works - Email (Services)
Megasync, does not work - photo backup
CloudBerryBackup, does not work - backup
Manuscript, works not - intended replacement for Scrivener

These three are problematic since they are in distro space (though I am a little confused about gimp since it is installed in flatpak so it shouldn’t conflict with the system gimp afaik, you should be able to uninstall with flatpak). swupd repair --picky is what you want to use to get distro content to be clean (this will remove content that shouldn’t exist). If you want to see what the repair will do, swupd diagnose --picky should show that.

1 Like


Chrome, deleted_
Tresorite, left
Sophos, left
Mailspring, deleted_
Megasync, left
CloudBerryBackup, left
Manuscript, deleted_

The result was not as expected. Got different results via swupd repair --picky and swupd diagnosis --picky, respectively, and swupd repair --picky-whitelist mailspring. I ended up using swupd repair --picky-tree=/usr

So only Manuscripts of, Manuscript, CloudBerryBackup, and Megasync were removed.
Also, Chrome, Mailspring was removed! Which was not the intention. But depending on the “-tree=/usr” extension I suppose. Maybe as good as that and in the future only use Flatpacks and AppImage files as intended?

Gimp seems to be below both usr/lib64 and usr/share!

Remains then Megasync, CloudBerryBackup and the extra version of Gimp to remove.


Found the following command: man swupd: stands for manual swupd?
Very good and informative.
Except then also swupd subcommand --help

But unfortunately, the result is not the expected, regardless of the use of repair --picky and so on.
Some folders appear to be exempt/excluded, including the ones I try to access.
So it doesn’t seem possible to access them there.
But they may not affect anything. In any case, the icons for the programs disappeared, so I can easily forget that they exist. Alternatively, a clean reinstallation will apply.
The extra copy of Gimp disappeared when I removed Gimp through programs. After all, where is a bundle for that.

I solved, well, the problem by doing a re-installation. End trial and error. No more rpm files.