My system fonts got messed up

i was trying out some rustic fonts, and then suddenly my fonts turned ugly and deformed, and it stays that way no matter what font i set it as.

Hi, have you tried “swupd repair”? Thanks to the stateless design you can easily fix the OS with swupd, using the repair command. This will check the integrity of the files to see if something has been compromised making it malfunction.
After that, if still isn’t back to normal another thing to try is to do a “System reset” as explained here:

With the commands:
sudo rm -rf /etc
sudo rm -rf /var

Hope it helps, in theory it should fix it.

its too late i already deleted my user account. that fixed it.
i dont understand how just removing /etc and /var will reset the system when /opt, /usr/local, and /home is in the userspace.

Ah, I see, sorry about that, well, just if it happens again maybe you can try it!

Regarding the system reset, I believe it just refers putting the default configuration of the OS rather than resetting the OS to make it look like a fresh install with no user files.