Swupd diagnose and swupd repair

Hi there,

I am running Clear Linux for a while and now it crashed suddenly while normal usage (start of Android Studio).

To see if there are issues on my system I ran:

sudo swupd diagnose

Indeed it showed a whole bunch of missing files and files which have a wrong hash.

So, I ran:

sudo swupd repair

The output is:

Inspected 248584 files
2169 files were missing
2169 of 2169 missing files were replaced
0 of 2169 missing files were not replaced
881 files did not match
881 of 881 files were repaired
0 of 881 files were not repaired


Repair successful

I reboot the system and check again with:

sudo swupd diagnose

Same output… Of cause I start the repair again. And same output again.
It keeps going that way. At this point I am not able to “repair” the system.

Am I doing something wrong?
Can someone else reproduce that behavior?


I can replicate this behaviour. I think this is the right way to do it, so I don’t think you are doing anything wrong. Don’t know what is going on though.

report a bug on github

I have the same issue.