Need Help Installing SoftMaker Office 2021

Hey guys, I followed the instructions to install SoftMaker Office 2021 on Clear (other distros as per the site)

https://www.softmaker.com/en/tips-linux

But I keep getting the following errors.

I get the error that I’m not a root/super user even though i’ve used both sudo ./installsmoffice and su followed by the said script

I get too many arguments in line 1340

I get installation aborted because the installer doesn’t find the file “office2021.tar.lzma” which is clearly over there.

also uploading content on line 1340 over here.

Can someone please help me? Thanks :slight_smile:

If their script is not working, you should ask them.

The “too many arguments” error is because your working directory contains spaces (the ‘all data here’ section). You can either correct that or change line 1340 to: cd “$SAVEDIR”

Hey guys. So the problem got solved. But can you please tell me what was the exact issue?

Here’s how it worked out.

I just copied the folder with the installation script file into the default Downloads folder under the home directory. It would only install from there. Even when I would make a sub-folder under the Downloads folder, it still would give me too many arguments.

@Tidda line 1340 is already $SAVEDIR as you can see in the shots I have atttached above. It’s a whole folder on imgur and the last image is about line 1340.

I’ll share it again over here anyway. Thanks. :slight_smile:

Share it at SMO forum too : https://forum.softmaker.com :wink:

cd $SAVEDIR is not the same as cd "$SAVEDIR"

It seems you missed the double quotes.
You moved the script to a directory with a path without any spaces, that solved it.