Newbie installation of rpm files goes wrong

I use a cloud service to store my documents, and sync them between computer and mobile. I recently switched from Win 10 to eminent ClearLinux. This led to, among other things, that since the cloud service does not offer a Linux app specifically for Linux, but an extension to the Chrome browser, I tried to install Crome. Google has a Chrome version in rpm format, which I understand? should be able to install on ClearLinux?
Through: for rpm in filename.x86_64.rpm; do rpm2cpio $ rpm | (cd /; sudo cpio -idv); done
But only get the error message “cpio: premature end of archive” when I try to install any rpm file.

What could have gone wrong?

I’m a little unsure why you’d need to loop over rpms, the chrome rpm I know of found is a single rpm for installing chrome. Seems like maybe the rpm archive you used has a problem.

I downloaded Chrome to the Google Store. Was linked there by the cloud service.
But, found the following link instead:


which turned out to work?
“It is important to search properly before making posts”.
Installed the cloud service extension, but it now shows as it says it may be damaged. There is a button to repair it, nor to update it. But it did’nt help. So there I am now.

The file you had a link to is the same one I used.

Most immediately obvious issue is that there’s an extraneous space between $ and rpm above.

1 Like

Have now tested to install with removal of spaces as suggested for $rpm.
It worked now, partially. None of them were fully installed, and did not work. The programs I tested were Megasync, and Cloudberry Backup.