Not happy with performance on my laptop

I have a Legion Y530 with an 8300H processor and 32 gigs of ram with an intel NVME drive. I was running Pop_OS! and everything ran smoothly as butter. But I wanted to give Clear a try since I like differences that Clear has and it was optimized for Intel, or so I thought, but it doesn’t seem so with my set up.

Upon first boot up, it seemed like it took forever to boot to log in screen. Then when I tried to go to the settings it just hung there. I had multiple things do that until finally, they decided to work. So I restarted my laptop and while bootup was faster it was nowhere near as fast as Pop and sadly Windows even boots faster. I still had a bit of hang on getting into settings, Firefox worked well though. and once settings came up it and were closed the next time I went to it, it was definitely snappier. After letting it do its thing the OS felt good. I then pretty pleased with the way the OS was reacting so then I tried to install some programs via the software store. Maybe it was me being impatient but I tried to install steam let it sit for like 30 seconds and it never got past 0%

I really wanted Clear Linux to be my go-to daily driver for Linux but I just can’t with the way it’s running on my laptop. If anyone has any ideas why it’s acting up on my laptop and how to fix them I would be grateful.

Hi @Philip, welcome to Clear Linux* Forum! :grin:

I think this is due to Flatpak runtimes being installed. The first time you download a Flatpak app — in this case Steam — Software installs the runtimes too. When you see 0% probably there are some dependencies in the install queue before Steam itself.

You should just wait until they are installed. The next Flatpaks — if they not require different runtimes — will be installed without the initial delay.

The other issues might just be related to first opening of programs. As you noticed, the following times they will open faster.

1 Like

Hey @Philip, welcome to the community! Sad to hear that. I’ll let the experts answer. I’ll be here listening though, in case of you need any further help.

Thanks, @MattiaVerticchio for the inputs. We appreciate it! :slight_smile:

2 Likes

Philip, do you have a spare SSD or HD ?

Maybe the NVME drive is the source of the hangs… I had the same problem recently.

I have a small laptop with NVME drive. I used F2FS (with arch, cpu doesn’t support clear) and saw amazing performance gains. Does clear support F2FS as root filesystem?

F2FS as the root is not something I’ve tried but it isn’t specifically supported (and by that I mean tested for being the rootfs). It could work though in theory.

Let’s investigate system logs by https://github.com/linuxhw/hw-probe#appimage

1 Like

I see infinite number of nouveau crashes in your probe dmesg: https://linux-hardware.org/?probe=1fb8a35227&log=dmesg

This may slow your system.

Could you please try a proprietary driver (https://docs.01.org/clearlinux/latest/tutorials/nvidia.html)?

[   20.373716] WARNING: CPU: 5 PID: 561 at drivers/gpu/drm/nouveau/nvkm/subdev/mmu/vmmgf100.c:221 gf100_vmm_invalidate+0x196/0x1a0 [nouveau]
[   20.373716] Modules linked in: joydev hid_multitouch 8250_dw btusb btrtl btbcm btintel snd_hda_codec_hdmi bluetooth ecdh_generic ecc mei_hdcp atkbd libps2 serio_raw intel_wmi_thunderbolt wmi_bmof snd_hda_codec_realtek sof_pci_dev snd_hda_codec_generic snd_sof_intel_hda_common ledtrig_audio snd_sof_intel_byt snd_sof_intel_ipc snd_sof snd_sof_nocodec snd_sof_xtensa_dsp snd_soc_skl snd_soc_hdac_hda snd_hda_ext_core snd_soc_skl_ipc snd_soc_sst_ipc snd_soc_sst_dsp snd_soc_acpi_intel_match intel_pmc_core snd_soc_acpi snd_soc_core rtwpci snd_compress uvcvideo rtw88 snd_pcm_dmaengine ac97_bus videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 mac80211 snd_hda_intel videobuf2_common snd_hda_codec videodev i2c_i801 media snd_hda_core snd_hwdep snd_pcm snd_timer snd soundcore cfg80211 r8169 nouveau realtek libphy idma64 virt_dma mei_me ucsi_acpi nvidiafb mei vgastate fb_ddc intel_lpss_pci intel_pch_thermal processor_thermal_device typec_ucsi intel_soc_dts_iosf typec i2c_hid ideapad_laptop battery
[   20.373729]  sparse_keymap rfkill int3403_thermal int340x_thermal_zone i8042 pinctrl_cannonlake wmi pinctrl_intel int3400_thermal acpi_thermal_rel ac pcc_cpufreq
[   20.373732] CPU: 5 PID: 561 Comm: gnome-shell Tainted: G        W         5.2.13-832.native #1
[   20.373732] Hardware name: LENOVO 81FV/LNVNB161216, BIOS 8JCN52WW 06/14/2019
[   20.373752] RIP: 0010:gf100_vmm_invalidate+0x196/0x1a0 [nouveau]
[   20.373753] Code: 8b 40 10 48 8b 78 10 4c 8b 67 50 4d 85 e4 75 03 4c 8b 27 e8 4c 9c 28 f9 4c 89 e2 48 c7 c7 ae d8 67 c0 48 89 c6 e8 79 2b be f8 <0f> 0b e9 70 ff ff ff 0f 1f 00 8b 87 cc 00 00 00 55 48 89 e5 83 f8
[   20.373754] RSP: 0018:ffffa70d844ef8d0 EFLAGS: 00010286
[   20.373754] RAX: 0000000000000000 RBX: ffff96bab16fe400 RCX: 0000000000000000
[   20.373755] RDX: 0000000000000000 RSI: 0000000000000000 RDI: 0000000000000000
[   20.373755] RBP: ffffa70d844ef928 R08: 0000000000000000 R09: 0000000000000000
[   20.373755] R10: 0000000000000000 R11: 0000000000000000 R12: ffff96ba6dc17840
[   20.373756] R13: ffff96bc4d70c600 R14: ffff96bb1b1c2e20 R15: ffff96b8806d77c0
[   20.373756] FS:  00007ff723728c00(0000) GS:ffff96bdce340000(0000) knlGS:0000000000000000
[   20.373757] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[   20.373757] CR2: 0000561591ee6068 CR3: 0000000732b22006 CR4: 00000000003606e0
[   20.373758] Call Trace:
[   20.373778]  gp100_vmm_flush+0x1a/0x30 [nouveau]
[   20.373797]  nvkm_vmm_ptes_unmap_put+0x1e6/0x2b0 [nouveau]
[   20.373815]  ? gf100_vmm_invalidate_pdb+0x30/0x30 [nouveau]
[   20.373833]  nvkm_vmm_put_locked+0x1d2/0x220 [nouveau]
[   20.373852]  nvkm_uvmm_mthd+0x3d9/0x780 [nouveau]
[   20.373863]  nvkm_object_mthd+0x15/0x30 [nouveau]
[   20.373874]  nvkm_ioctl_mthd+0x60/0x80 [nouveau]
[   20.373885]  nvkm_ioctl+0xee/0x1a0 [nouveau]
[   20.373907]  nvkm_client_ioctl+0xd/0x20 [nouveau]
[   20.373917]  nvif_object_ioctl+0x49/0x80 [nouveau]
[   20.373928]  nvif_object_mthd+0x12e/0x160 [nouveau]
[   20.373939]  ? nvkm_ioctl_del+0x37/0x60 [nouveau]
[   20.373949]  ? nvkm_ioctl+0xee/0x1a0 [nouveau]
[   20.373960]  nvif_vmm_put+0x40/0x70 [nouveau]
[   20.373982]  nouveau_vma_del+0x5a/0xb0 [nouveau]
[   20.374004]  nouveau_channel_del+0xa9/0x120 [nouveau]
[   20.374025]  nouveau_abi16_chan_fini.isra.0+0xaf/0x130 [nouveau]
[   20.374046]  nouveau_abi16_ioctl_channel_free+0x4e/0x90 [nouveau]
[   20.374067]  ? nouveau_abi16_usif+0xe0/0xe0 [nouveau]
[   20.374068]  drm_ioctl_kernel+0x94/0xd0
[   20.374069]  ? ttm_mem_global_free_zone+0x1b/0x70
[   20.374070]  drm_ioctl+0x249/0x430
[   20.374091]  ? nouveau_abi16_usif+0xe0/0xe0 [nouveau]
[   20.374092]  ? ttm_mem_global_free+0x13/0x20
[   20.374113]  nouveau_drm_ioctl+0x73/0xc0 [nouveau]
[   20.374115]  do_vfs_ioctl+0x431/0x630
[   20.374116]  ksys_ioctl+0x6a/0x90
[   20.374117]  __x64_sys_ioctl+0x15/0x20
[   20.374118]  do_syscall_64+0x59/0x1f0
[   20.374120]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[   20.374120] RIP: 0033:0x7ff72830e44b
[   20.374122] Code: 0f 1e fa 48 8b 05 35 3a 0d 00 64 c7 00 26 00 00 00 48 c7 c0 ff ff ff ff c3 66 0f 1f 44 00 00 f3 0f 1e fa b8 10 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 05 3a 0d 00 f7 d8 64 89 01 48
[   20.374122] RSP: 002b:00007ffee33e7ae8 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
[   20.374123] RAX: ffffffffffffffda RBX: 0000000040046443 RCX: 00007ff72830e44b
[   20.374123] RDX: 00007ffee33e7b28 RSI: 0000000040046443 RDI: 000000000000000e
[   20.374124] RBP: 00007ffee33e7b10 R08: 0000560df559e012 R09: 0000000000000002
[   20.374124] R10: 00007ff7139d368c R11: 0000000000000246 R12: 00007ffee33e7b28
[   20.374124] R13: 000000000000000e R14: 00007ffee33e7bb8 R15: 00007ff71382a092
[   20.374125] ---[ end trace d8ed03475cd7f670 ]---
[   20.448063] SAME REV: no_force Returning NO_NEW old = 0xb4 new = 0xb4
[   20.944149] nouveau 0000:01:00.0: i2c: aux 0004: begin idle timeout bad00100
[   21.263770] nouveau 0000:01:00.0: i2c: aux 0006: begin idle timeout bad00100
[   23.438075] ------------[ cut here ]------------
[   23.438076] nouveau 0000:01:00.0: timeout
1 Like

Would it be possible to disable the Nvidia graphics? I don’t plan on gaming when booted into clear. I was just testing out the software store and picked steam to download.

I wanted to boot into Linux so I don’t get distracted by wanting to play games. Also I wanted to see if my battery life would be better while working on school work.

Follow the instructions to disable nouveau driver: https://docs.01.org/clearlinux/latest/tutorials/nvidia.html#disable-the-nouveau-driver

And then reboot and make a probe again.

2 Likes

I can already see a difference, boot time has increase dramatically as well as response to get to the settings… Everything is snappy as can be and I’m quite happy with the performance now. So if there happens to be anything else wrong that can speed it up that would be way awesome!

1 Like

Now it looks fine.

The minor remaining improvement would be to disable kernel debug printing by removing the initcall_debug boot option. This may speed up boot and allow us to look at the complete dmesg output.

sudo mkdir -p /etc/kernel/cmdline-removal.d
echo "initcall_debug" | sudo tee /etc/kernel/cmdline-removal.d/initcall_debug.conf
sudo clr-boot-manager update

And as usual reboot and make a probe for further investigations.

Here is the new link, thanks for all the help to get Clear working well and expanding my knowledge of Linux. https://linux-hardware.org/?probe=45ff155f8e

2 Likes

Thank you this helped me as well, after installing the Nvidia drivers my ThinkPad P52 behaves at a normal speed, instead of acting like it’s being submerged in mud.

The only further issue I encountered is after rebooting, I got a Gnome “Uh-oh, something went wrong, please contact your system administrator” error. After a clue I found from googling around, I tried going into the BIOS and switching the graphics device from “Hybrid” to “Discrete”. After that settings change, my computer booted without problem and works like a dream now.

2 Likes