Radeon™ Pro WX 9100 with kernel-lts2018-preempt-rt

Hi Members,

I am planning to use Radeon™ Pro WX 9100 with kernel-lts2018-preempt-rt. Can some help to understand the Radeon™ Pro WX 9100 driver compatibility issues with selected kernel .

It will be a great help.


The open source drivers should work for you - we don’t have the hardware to test this but I believe that it is at least supported by the -native kernel. This device is from 2017, so it may not be supported by the 2018 lts - someone would have to confirm that. Your best bet is to try the live desktop ISO image.

just for curiosity:

Why do you want to use kernel-lts2018-preempt-rt?

It is targeted for use as real time linux, and for IoT usage.


I tried with -native kernel with Radeon™ Pro WX 9100 GPU but with no success. Below are the section of Xorg logs. Any help will be appreciated

[ 9.742] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[ 9.742] (II) Module glamoregl: vendor=“X.Org Foundation”
[ 9.742] compiled for 1.20.4, module version = 1.0.1
[ 9.742] ABI class: X.Org ANSI C Emulation, version 0.4
[ 9.746] (EE) AMDGPU(0): eglGetDisplay() failed
[ 9.746] (EE) AMDGPU(0): glamor detected, failed to initialize EGL.
[ 9.746] (WW) AMDGPU(0): amdgpu_glamor_pre_init returned FALSE, using ShadowFB


I was able to bring up Radeon WX9100 with kernel-native. Issue was the machine was initially having Nvidia graphics card and its proprietary driver in working condition and I replaced it with AMD card assuming open source drivers AMDGPU and RADEON are already there as a part of linux kernel, but It didn’t work.

Once I reinstalled Clearlinux it worked straight away. So My theory is , there may be some conflict between AMD open source drivers and Nvidia proprietary driver(which makes some changes in linux graphics stack in both user and kernel space).

I just hope it should work with RT-kernel in similar manner. I will try it today

Thanks community members for all your support.