Setup Silent Boot on Clear Linux

Hello anyone. I’m newcomer on Clear Linux, but I have some experience in other distros. My question is how to setup silent boot in Clear Linux, but I can get verbose log from it. I’m successfully to suppress boot log, but it can’t hide log from shutdown process. How should I do to do that? Thanks for your help, and sorry my English :pray:t3:

our boot normally is silent by default
(but not in our installer images on purpose – there we want full information)

But in my machine, by default is not more silence than other distros. In my case, in shutdown process I always seem verbose log on shutdown process. How must I do to hide it?

I’m unsure if this can help silence warnings during shutdown. This adds quiet loglevel=3 to kernel arguments.

sudo mkdir -p /etc/kernel/cmdline.d
echo "quiet loglevel=3" | sudo tee /etc/kernel/cmdline.d/silent.conf
sudo clr-boot-manager update

I add it to my machine but it only supress verbose log on starting system only

I mean like this, @marioroy & @arjan
Shutdown process video

Something or i2c segfaulted there. Have you tried tuning printk?

sudo sysctl -w kernel.printk="3 3 3 3"

To persist, append a line for the clear power tweaks service. The file does not exists, typically.

echo "/proc/sys/kernel/printk 3 3 3 3" | sudo tee -a /etc/clr-power-tweaks.conf

This was helpful, particularly understanding what each of the four numbers mean. The following article describes kernel.printk.

I changed kernel.printk sysctl value but not affected to my machine

$ sudo sysctl -a | grep printk          
kernel.printk = 3	3	3	3
kernel.printk_delay = 0
kernel.printk_devkmsg = on
kernel.printk_ratelimit = 5
kernel.printk_ratelimit_burst = 10
kernel.tracepoint_printk = 0

I set it on /etc/sysctl.d/20-quiet-printk.conf

Try decreasing the log level. Or last resort, console=/dev/null.

  1. kernel.printk = 0 0 0 0
  2. kernel arguments quiet loglevel=0
  3. kernel arguments quiet loglevel=0 console=/dev/null

By the way, in other distro, 3 3 3 3 of kernel.printk value is much for suppress shutdown verbose log, but it’s have Plymouth to help suppress it. In my kernel arguments too I add quiet loglevel=3 and it can run silent boot. Only in Clear Linux I can’t setup silent boot on shutdown process.

I’m a normal Clear Linux user and out of options. It appears i2c crashed in the video. Have you tried disabling the problematic driver? Perhaps in other distros, the i2c driver is not failing during shutdown.

This may be unrelated.

How you can judge thats driver is failing? I can’t get idea how you conclude it

Hi, four seconds into the video i2c_smbus_read_block_data crashed?

So, just modprobe -r drivername, right? In this case is i2c_smbus


Yeah, solved. I remove i2c kernel mode with rmmod, modprobe, and blacklist it

# rmmod i2c_i801
# rmmod i2c_smbus
# modprobe -r i2c_i801
# modprobe -r i2c_smbus
# mkdir /etc/modprobe.d
# vi /etc/modprobe.d/blacklist.conf

Add two lines to opened Vim

blacklist i2c_i801
blacklist i2c_smbus

Save and update bootloader with sudo clr-boot-manager update