Slow after latest update

Hi guys just installed the new 37670 version I think and is not loading gnome it is an issue operating as I am seeing my background black and changing screens is an issues cant use the main menu too shacky . Can you assist me rollback the version

Go back to last previous known working Clear Linux build number for you with instruction from the
link shown below:
How to revert bakc to earlier versions · Issue #456 · clearlinux/swupd-client (

I have used a less verbose version of this and it has worked for me.

It says the option has been superseded

Using the swupd update --help
The pertinent comments about usage are shown below:
-V, --version=V Update to version V, also accepts ‘latest’ (default)

You would use:
swupd --version

I mean use:
swupd --version <Clear Linux Build number you want to revert to>

I needed to “escape \<\>” brackets so they and the comments could be seen.

hii still having some issues when I use it here is the response
49a8c4a89917edc335a0e3afb~ $ sudo swupd --version 382
swupd-client 5.0.5
Copyright (C) 2012-2019 Intel Corporation

Compile-time configuration:
mount point /
state directory /var/lib/swupd
bundles directory /usr/share/clear/bundles
certificate path /usr/share/clear/update-ca/Swupd_Root.pem
fallback certificate path /usr/share/ca-certs/.prebuilt-store/anchors
config file path /usr/share/defaults/swupd:/run/swupd:/etc/swupd
systemd unitdir /usr/lib/systemd/system
content URL
version URL
format ID 34
build number 382
pre-update hook
post-update hook /usr/bin/update-helper

sudo swupd repair --picky --version=version

it just checks for corrupt files does not revert

I did this with force earlier then it checked all files then am still on version 39670

This is a correction for how to revert in swupd see below:

It is not working I tried 39630 or 382 can you suggest a recent build number

I just did:

sudo swupd repair --picky --version=39630

Now I’m back on version 39630 (from 39670).
Updating to 39670 again…

great mine worked tooo whats with version 39670 does it have different requirements? or requires maybe upgrades in hardware

my views were the only problem seems too have some kind of overlay on the screens dark background

I have the same question

update to 39690 lets goo

anybody using the latest version

Currently on 39750. No major issues.

ok for my last update was bad hope updating won’t crush my laptop again