[SOLVED] Can anyone help me configure the bootloader

i need to add pci=nomsi to the bootloader can anyone help me

Never encountered the issue before that I had to change the boot options, but the below is what I would try first. Fingers crossed it works…

rip@Clear1~ $ sudo -i
root@Clear1~ # systemctl start boot.mount
root@Clear1~ # cd /boot
root@Clear1/boot # ls -R
.:
EFI loader

./EFI:
BOOT org.clearlinux

./EFI/BOOT:
BOOTX64.EFI

./EFI/org.clearlinux:
bootloaderx64.efi freestanding-i915-firmware.cpio.xz kernel-org.clearlinux.native.5.7.7-967
freestanding-00-intel-ucode.cpio kernel-org.clearlinux.native.5.7.6-966 loaderx64.efi

./loader:
entries loader.conf

./loader/entries:
Clear-linux-native-5.7.6-966.conf Clear-linux-native-5.7.7-967.conf
root@Clear1/boot # clr-boot-manager list-kernels

  • org.clearlinux.native.5.7.7-967
    org.clearlinux.native.5.7.6-966

root@Clear1/boot # vi ./loader/entries/Clear-linux-native-5.7.7-967.conf # add options here
root@Clear1/boot # cd
root@Clear1~ # systemctl stop boot.mount
root@Clear1~ # logout
rip@Clear1~ $

‘ozcanberkciftci@clr-313b9285431b430494a236f0f667495d~ $ sudo -i
root@clr-313b9285431b430494a236f0f667495d~ # systemctl start boot.mount
root@clr-313b9285431b430494a236f0f667495d~ # cd /boot
root@clr-313b9285431b430494a236f0f667495d/boot # ls -R
.:
freestanding-00-intel-ucode.cpio ldlinux.c32 org.clearlinux.native.5.7.7-967
freestanding-i915-firmware.cpio.xz ldlinux.sys syslinux.cfg
root@clr-313b9285431b430494a236f0f667495d/boot’

can you tell me what to do after this

This is clearly a different type of install than mine so I’m just guessing at this point, but I would inspect /boot/syslinux.cfg as that is the most likely candidate of the files there to add some options.

1 Like

ok i found “quiet” there and added pci nomsi next to it and saved it so now do i need to run a command for example update-grub

I don’t have grub on my system (well, actually I do, but unused when booting in Clear Linux) but I don’t expect that to be necessary, I would hope a simple reboot would do.

i dont use grub as well i just asked if there was an command that was required for changes to take effect.ty for your help rebooting now.

thank you so much for your help. it fixed it! i can finally use a distro now without problems. :slight_smile:

1 Like

Glad to hear it! Hi Five :grin:

2 Likes