Failed boot after install

Clean install. All intel Lenovo Slim 7. Nvme drive

I had to install 37860 without network.


disable auto update, log into my network and then update to newest build (released 7/14) CLI.

It worked, surprisingly.

I’m not a huge fan of gnome, but it’s in a partition on my laptop just for testing.

Weirdly enough it made its own 150M boot partition, didn’t use the one I already had with 3 other distroa…

I am not an expert. It is worth pressing F8 while booting and see what boot drives are available. If there are two different boot options, you can try each. You can also re-install a different version from here, perhaps the latest.

I’m no expert either but people will need more information.

Is it server or desktop? Did you manage to boot the live version without installing?

What is your partition scheme for the installation?

You’re right My bad. I forgot this is server focused distro.

Default partition scheme (entire disk). Desktop install (not server).

Installed from inside the live session that was running.
Vanilla install with no additional packages.

39400 iso downloaded from website link. Downloads | Clear Linux* Project

Im downloaded the newest iso from the releases link provided by Indy

Press Ctrl + Alt + F3 > login with your username and password > sudo swupd update && reboot

if you cant open a TTY (Terminal) Download the 39590 version iso

Same result with 39590…

It’s fine

I’ve tried others that ‘blew up’ for me. I don’t take it personally.

My drive got hosed and I thought I’d try something different, since I had to configure stuff again anyways for reinstall

Can’t pull up a tty either. I get the error the screen blanks and 1 underscore @ top left, solid - not blinking. Can’t input anything.

Same here, live iso works and after installation only underscore in the left top corner

@Brian_Francisco and @Ramazan_Ince I am quoting @marioroy

During setup, remember to enter [A] Advanced options. Select “Kernel Command Line” and enter nomodeset 3 to “Add Extra Arguments”. Optionally, go back to the prior screen and choose the lts (recommended) or native kernel under “Kernel Selection”. Also disable automatic OS updates if desired.

Worth trying this. Also it would help to know what graphics hardware you both have.

Having the same issue on my new laptop computer (2023 LGGram), purchased yesterday. The screenshot below shows the boot sequence on my old, perfectly functioning, computer. Interestingly, the “Linux bootloader” line is missing from my new computer on which I am attempting to install CL, hence it appears that, for some reason, the CL install script no longer creates this entry. I will be poking around in the BIOS to see if there may be something there that prevents CL from creating this entry. Alternatively, I will attempt to install Ubuntu, see how that works. I will also try to install an older CL version (37860 or whatever), to see if that works. Will report back.

I had issues as well when i first installed, could not get it to boot in UEFI mode, only legacy.

Had to disable legacy bios compatibility and reinstall Clear Linux with UEFI only mode enabled in the “bios”.

I’ve poked around in BIOS for a “legacy BIOS compatibility” mode, and couldn’t find anything to that effect. And yes, I did switch to advanced BIOS (Ctrl+Shift+Alt+F7). Where did you find that setting? Could you please be more specific?

Not sure if it’s your exactly setup but the option is in Advanced > Legacy OS boot > Disable

That’s what i did and then reinstalled my system without legacy boot enabled .

Thanks. Looks like that setting is no longer there anymore, at least not on newer BIOSes.

I’m seeing some additional context when booting from the LiveUSB i used previously to install the system. Attempting to recover the system with the Guide for liveUSB recovery.

If the system is not booting i would attempt to disable Secure Boot or make sure it’s disabled

And if there’s no secure boot or legacy bios option in the “bios” setup i would try to press f8 or f12 when booting to get to more boot options and attempt to disable both in there.

Doing a repair/upgrade to 39600 seemed to get rid of the bluetooth hci0 codec business. Now i’m just left with the typical Spectre v2 warning and no bootloader or TTY sessions available for now.

Alright guys, here’s what works: install 37860 (yeah, that old!) making sure you disable automatic updates(!), reboot (yes, it will work!), and then do a sudo swupd update.

That worked for me. And yes, we should let the devs know that later releases have issues with newer BIOSes.


will try later tonight and report back! thanks for narrowing down a version!

I am also not able to boot after fresh install. I just downloaded clear linux to an usb. It booted and install successfully to my sony vaio VPCSB3S9E. But not able to boot. It stucks after some bluetooth message. the cursur blinks in the top left corner. Not getting the gui.

Another sony vaio also had similar problem, but arch linux running successfully. Arch shows the error but runs. Clear linux hangs there.

Please help.