Stuck at boot after updating from 38990

Solved after fresh install

I have a Amd rx 6500xt. Someone else getting this too? hope this helps and thanks in advance

xorg log:

[ 13.520] (II) LoadModule: “amdgpu”
[ 13.520] (II) Loading /usr/lib64/xorg/modules/drivers/
[ 13.522] (EE) Failed to load /usr/lib64/xorg/modules/drivers/ /usr/lib64/xorg/modules/drivers/ undefined symbol: amdgpu_pixmap_index
[ 13.522] (EE) Failed to load module “amdgpu” (loader failed, 0)
[ 13.522] (II) LoadModule: “ati”
[ 13.522] (II) Loading /usr/lib64/xorg/modules/drivers/
[ 13.523] (II) Module ati: vendor=“X.Org Foundation”
[ 13.523] compiled for 1.20.11, module version = 19.1.0
[ 13.523] Module class: X.Org Video Driver
[ 13.523] ABI class: X.Org Video Driver, version 24.1
[ 13.523] (EE) ati: module ABI major version (24) doesn’t match the server’s version (25)
[ 13.523] (EE) Failed to load module “ati” (module requirement mismatch, 0)

“flatpak update” gives this error message:

flatpak: symbol lookup error: /usr/lib64/ undefined symbol: g_string_free_and_steal

grmp more X-is-falling-apart mess; I will take a brief look but nobody is working on X or the AMD driver upstream anymore while the rest of the world (Mesa etc) move forward… it’s harder and harder to just keep it basically working

but … does Wayland work?

gdm wasnt even showing up so i couldn’t start and try wayland. I formatted boot,root & swap and reinstalled with 39210 iso and everything worked. I only remeber that I deleted accidently some partition from clearlinux when installing windows on an other harddrive and then reinstalled clearlinux (advanced installation) with an older clearlinux iso I had on my usbstick maybe that was the problem.