Unable to run Steam games on a non-flatpak install

CL: 40060 (clean install)
Bundles added: games-dev, wine, os-core-dev, libreoffice.
Additional Changes:
ln -s /usr/lib32/ld-2.24.so /usr/lib
from phoronix forums
for i in `ls /usr/share/vulkan/icd.d/*x86_64*`; do cp $i `echo $i | sed 's|x86_64|i686|g'`; done
sed -i 's|lib64|lib32|g' /usr/share/vulkan/icd.d/*i686*
above command is basically “creating” the missing i686 loaders and pointing them to lib32 folder.

Followed the guide here Here's How To Setup Clear Linux For Intel Steam Linux Gaming - Phoronix to install Steam. Games install fine and the client works but the games do not run at all. Both games I’ve tried are stuck at the play button and does not go to the splash screen.
log for dota2 gist
log for omega strikers gist
Steam Runtime System Information gist

As for this post, I cannot find ld.so.cache in /etc/ and steam has since moved on to sniper (v3.0) from soldier (v2.0) and the paths also seem to be different.

Using the option STEAM_RUNTIME=0 gives

You are missing the following 32-bit libraries, and Steam may not run:

Is there any way to get this running on Native Steam?

Try installing the games-dev bundle, seems to contain a lot of important libs to get steam working.