USB HDD reports insufficient power in dmesg

It works on my windows machine. I’ve tried 2 different hubs and the internal usb on the linux box.

dmesg says “rejected 1 configuration due to insufficient available bus power”

I found a way to fix it using

echo 1 > /sys/bus/usb/devices/2-1/bConfigurationValue

Is this worth opening an issue on Github? It’s only happened once.

Edit. It resets when I reboot. I’ll run the script on boot up. You have to “sudo chown user:group /sys/bus/usb/devices/2-1/bConfigurationValue” again too.

.

Hi @Sscratchie.
Did it happened since the last update?
Because I’m experiencing a similar issue since today: when I turn on the computer, once ClearLinux starts, all USB devices are turned off :sweat_smile:
The way I made it work was selecting the previous working version from the boot menu.

It was working fine till a few days ago. I don’t really see the updates but I’d have to guess that’s when it broke.

My USB stick works.It’s only the HDD.

I like your fix better. I still haven’t gotten the script to work at startup. I had to fix crontab first. “Editor:nano crontab -e” works.

My PC is randomly going into sleep mode too.

I’ll go look for the boot menu now.

:sweat_smile:

I noticed a few new issues in the Github repository (https://github.com/clearlinux/distribution/issues) related to the latest kernel update.

I’m running this on a NUC. I thought Intel would test it on their own products before release.

How did you get to the boot menu.I can’t find grub. Nothing is where I expect it to be.

I’ve tried LS RS ESC. on boot :frowning: Nothing.

NUC and Clearlinux are two separate projects. So NUC is not a “own product”

CL doesn’t use GRUB, but systemd-boot

I got the boot menu pressing “ESC” many times until the menu appears.

The About page says
“The Clear Linux team uses multiple methods to optimize for performance on Intel products:”

This NUC is an Intel product and has nearly all Intel parts. Graphics, PCI, audio, bluetooth, bios and processor. Must be the Kingston ram. They should have used Intel HMB2.