USB install error on XPS 13 9370 - Wrong EFI loader signature


I’m having issues with the USB installer on a Dell XPS 13 9370. I get Wrong EFI loader signature error (see image below).


This laptop originally came with Windows. I removed Windows and installed Ubuntu. I’m now trying to install Clear but I get error: Wrong EFI loader signature.

Laptop Specs

  • SATA Opearation > AHCI
  • Secure Boot > Disabled
  • Advanced Boot Options > Enable Legacy Option ROMs
  • 8th gen i7

Boot Images:



The solution ended up being related to a faulty USB device.

Is this the first boot from the USB image, or the second boot of the (newly) isntalled clearlinux?

Are you dual booting with Ubuntu? Is that the GRUB bootloader?

This is the first boot from the USB image (clearlinux has not been installed yet)

I want to overwrite Ubuntu. I get the error right after this screen:

I created the USB installer using Rufus (followed steps from clearlinux website). I also tried creating it with Etcher - same result.

UPDATE: I tried booting (using same USB installer) and got the following error:

I’m leaning towards the USB installer being corrupt… I’ve tried downloading and writting the USB many times with the same result though. Any suggestions?

First thing to try would be a 2-week old image instead of the latest one. It’s entirely possible there’s a bug with the latest version we haven’t spotted yet. Try maybe this one:

(server image should be quicker to try since it’s smaller).

A bad sector (that writes OK but fails to read) is another logical cause, but perhaps less likely.

Thanks for the help, @ahkok . It turned out to be my USB device. I purchased a new USB drive, downloaded the latest clear linux installer and everything worked perfect. Thanks for the help!