Vulkan error on Unreal Engine 4 games

Hi everyone,

Cool distro - really liking it so far. I’m running a cloud service for streaming games through WebRTC where the game runs headless without the display - all good. Nvidia drivers up and running, decent start times, low size requirements - amazing.

But I can’t seem to get Vulkan support working with my nvidia card and the documentation on how to do so is pretty scarce. As I’m running in the cloud on a VM, are there any solutions with minimal size requirements - I’m trying to reduce the filesize of the VM as much as possible.

I’ve tried installing the mesa bundles, opengl, vulkan-loader bundles but I still get the same error on my game:

Error [GENERAL | | OpenXR-Loader] : RuntimeManifestFile::FindManifestFiles - failed to determine active runtime file path for this environment
Error [GENERAL | xrEnumerateInstanceExtensionProperties | OpenXR-Loader] : RuntimeInterface::LoadRuntimes - unknown error
Error [GENERAL | xrEnumerateInstanceExtensionProperties | OpenXR-Loader] : RuntimeInterface::LoadRuntimes - failed to load a runtime
Error [GENERAL | xrEnumerateInstanceExtensionProperties | OpenXR-Loader] : Failed to find default runtime with RuntimeInterface::LoadRuntime()
Error [GENERAL | xrEnumerateInstanceExtensionProperties | OpenXR-Loader] : Failed querying extension properties
[2022.01.15-23.46.36:801][ 0]LogHMD: Failed to enumerate extensions. Please check that you have a valid OpenXR runtime installed.
[2022.01.15-23.46.36:801][ 0]LogVulkanRHI: Display: Not using instance layers

[2022.01.15-23.46.36:813][ 0]LogRHI: Warning: Failed to find entry point for vkDestroySurfaceKHR
[2022.01.15-23.46.36:813][ 0]LogRHI: Warning: Failed to find entry point for vkGetPhysicalDeviceSurfaceSupportKHR
[2022.01.15-23.46.36:813][ 0]LogRHI: Warning: Failed to find entry point for vkGetPhysicalDeviceSurfaceCapabilitiesKHR
[2022.01.15-23.46.36:813][ 0]LogRHI: Warning: Failed to find entry point for vkGetPhysicalDeviceSurfaceFormatsKHR
[2022.01.15-23.46.36:813][ 0]LogRHI: Warning: Failed to find entry point for vkGetPhysicalDeviceSurfacePresentModesKHR
[2022.01.15-23.46.36:814][ 0]LogLinux: Warning: MessageBox: Cannot find a compatible Vulkan device or driver. Try updating your video driver to a more recent version and make sure your video card supports Vulkan.

I’m running the game off screen so there’s no need for a running X server - the same nvidia driver works perfectly on Ubuntu 18.04 - fails on CL.

Thanks, if you need anymore information to diagnose and advise, let me know.

Here’s the full log, the readonly drive isnt causing the issue! Increasing per-process limit of core file size to infinity.- Existing per-proc -