Looking for Vulkan ICD loader

Hi, im looking for Vulkan ICD loader package because i need this to get working DXVK. I tried to install bundle-add games-dev but my game is still not runing. Maybe i should try to get this by DNF? Logs below.
Here is a dxvk log:
info: DXVK: v1.4.3
warn: OpenVR: Failed to locate module
info: Required Vulkan extension VK_KHR_get_physical_device_properties2 not supported
info: Required Vulkan extension VK_KHR_surface not supported
info: Required Vulkan extension VK_KHR_win32_surface not supported
err: DxvkInstance: Failed to create instance

and here is vulakninfo output:
https://pastebin.com/jxKUsZBG

I just readed here https://community.khronos.org/t/i-can-not-get-vulkan-to-work-with-mesa-drivers/7393 that problem can be caused when radeon driver is loaded eriler than amdgpu but sudo lshw -c video otuput gives me info that im using amdgpu

Do you have sources you can share so we can try as well?

It’s possible that you are missing the file you need, which appears to be (from looking at our sources) /usr/include/vulan/vulkan_core.h.

Or somehow the compilation process isn’t finding this file properly. Check and see if you have the file, or whether the game allows you to point to the proper location for Vulkan headers.

As for the radeon driver, I don’t think we ship it? It shouldn’t be an issue, because you compilation process fails, and not running the game. Compilation doesn’t actually use your hardware.

What game is this?

The file is exist but i don’t know how to check is wine have proper location for this.
I found on DXVK wiki that with this issue i need to install these libraries:


But idk where i can get this or did i have allready installed this.
Or wine from clear repo dosnt support vulkan maybe this causing problem? Because steam proton games works fine.
It’s Gang Beasts trying to get this by wine because for some reasons native wont work for me.
Also GTA V from rockstar launcher give same output.

wine in clearlinux does support vulkan but not vkd3d yet. I’ll see if I can get this enabled. Steam proton support uses a different copy of wine and not the one that clearlinux provides.

So i will try to compile wine for my self and check if this working.
Also if u will something do with wine check this: https://github.com/Joshua-Ashton/d9vk
It will nice to have to get wine with dxvk and d9vk from repo.
Also i didnt see utlis for xbox 360 pad can u check this? Maybe it should be in game bundle.

Looks like I’ve successfully enabled vkd3d in wine. Next I’ll look at DXVK and see what it needs.

2 Likes

The games bundle includes the Vulkan loader libs. This suffices for lutris which uses DXVK.

I’ve got GTA V working with lutris FWIW, using its recommended version of wine, DXVK, and a custom /etc/vulkan/icd.d for nvidia.

I didnt used lutris maybe I should? But In my opionion still it will be greate when wine from repo will suport this

In the current state of Linux gaming, I think frameworks like Lutris that provide a library of blueprints/best-known configuration per game are really useful. Definitely check it out so you know it’s capabilities and know you have it as an option.

Agreed, native is even better. The nice thing, from what I can tell, is many of the improvements are getting upstreamed into wine. Some games I was able to just let use the native wine installation.

I think I may have a working DXVK build … It’ll be part of the wine bundle in a few days as well!

Edit: Since (for some reason) wine isn’t included as part of games, this will just be part of the wine bundle alone.

2 Likes

So I’ve worked out what’s wonky with this https://github.com/clearlinux/distribution/issues/1437

So any 32bit vulkan won’t work with AMD and intel vulkan drivers, i.e. d9vk and dxvk on 32bit games (whether you compile it yourself, use steam/proton etc). It should be easy to fix and then they’ll magically start working!

3 Likes

So steam is using 64 bit libraries? Because i try to run same game on steam by proton and it’s works. Than i tried by lutris with proton executable and I noticed same errors that before.

In lutris i can choose icd_loader_x86_64
Or maybe it’s flatpak reason

Yes in places and 32bit elsewhere. wine/proton have 32bit and 64bit modes. Proton may prefer a 64bit wine prefix, whereas 32bit ones are much more common. There’s many variables and you would likely have to ensure each part is using the 64bit arch/version/binary for it to work (i.e. calling wine64 rather than wine).

At this point it’s best to wait, try the update and see (I’d guess first update next week with version >=31480). This was fixing an issue myself and @ahkok could reproduce with the same dxvk error as in the first post, with it being working after the change (covering AMD and Intel cards).

1 Like

Steam embeds it’s own wine copy, independently of the one provided by clearlinux.

Yeah but i tryed tu use steam proton executable by lutris and it dosnt work too.

I just checked steam flatpak source


And i saw that this provide own icd loaders so I think thats why its working by steam.

BTW. Wine from repo also is not builded with ESYNC support.
Is there is a way for normal user to build some packages and push it to bundles? So maybe i can handle this.

Just compile and install it into /usr/local. No need to bundle or anything.

Oh i mean to push it to repository of clear linux to help another people.

Just post your patch and we’ll review/merge it. I’m not so sure whether we want to merge esync since it’s out of tree. If upstream wine doesn’t want to consider it, then we’re likely not going to enable it. But, we can take a look for sure.