What could keep a game from fully launching?

The game is Astroneer. It is installed with Steam, and runs with Proton 5.0-2. I can run this game in Mint, and Pop! OS. I also use Left 4 Dead 2 with Proton in CL without a problem.
Astroneer can start but right after the splash image it closes without an error message or anything else.
I have tried using the previous version of Proton (4.11-12) without avail.

How to at least see the terminal output and/or logs?
Or better yet, does anyone have a good idea of why this is happening, or how to fix it?

I opened a Terminal from the location where the game executable is located and tried to run it with “wine Astro.exe”. That called for Wine to be installed, so I had Wine installed. Once done nothing happened after. I ran the command line again (wine Astro.exe) but it would just bring me back to the white blinking rectangle (cursor) :frowning:

Then I used this other command line:

steam steam://rungameid/361420

But it replied:

steam: command not found 
To install steam use: sudo swupd bundle-add games 

But Steam is installed. In fact right from the Gnome software app from Clear Linux. Would the Clear Linux system get messed up if I were to install Steam as it is suggested above?

Thanks guys!

Now I can see the Terminal output. Thanks to mandiblesarecute:

flatpak run com.valvesoftware.Steam

Ok, these are the Terminal Outputs for Steam, Astroneer, and Blender.
Steam Terminal Output URL: https://pastebin.com/FTnxprfA
Astroneer Terminal Output URL: https://pastebin.com/yRvzx72T
Blender Terminal Output URL: https://pastebin.com/V5W4fDSt

Bonus, I just noticed that No Man’s Sky is in the same boat: https://pastebin.com/RirGjicb

The output from Blender is just to show what the Terminal Output looks like when the app succeeds to open.

Not all Proton enabled Windows games will work under Linux. That is not a defect of ClearLinux, or even a defect of Flatpak, or even a defect of Steam.

In this case, the Windows game crashes. It is likely incompatible with Proton. You’d have to send a bug report to Valve - this game might just not work under Linux at all - ever.

True. I understand that.
EXCEPT, I do play this game in 3 OSs: Windows 10, Mint 19.3, and Pop! OS 19.04.
Just between Windows 10 and Mint I have played it for over a year now. Funny thing is, it plays better in Linux, go figure! :wink:

Have you had a look at the Terminal Outputs, the answer should be there. I am just not that knowledgeable to uncover the mystery :frowning:

As ahkok said in another post the forum is not a support service. You can’t really expect a developer to go through the terminal outputs just to find out why this particular game didn’t work on CL.
Of course you’re going to be disappointed, but give the developers some slack. :slightly_smiling_face:

1 Like

FAIR ENOUGH! Thanks for that Portage :slight_smile:
Sorry about that ahkok :relieved:

Would you care to share a support forum for CL?
I would really appreciate it.

1 Like

I don’t own these games, so, I can’t inspect the output that these games generate.

Plenty of Proton games work on my system, so, it’s likely something game specific that doesn’t work, and without owning the game, I can’t trouble shoot it.

I understand.
Also, while seeking help elsewhere I came to the realization that I have not installed the Nvidia drivers. Maybe I should start there.