Where to find "granite"

I’m fairly new to “Clear Linux”. I’m accustomed to the other distros that have package managers using apt-get.
With Clear Linux, it seems that there is some assembly required. I’ve learned quite a bit since starting this adventure.

With that said, I’m trying to install a better functioning menu editor for gnome. The flatpak one doesn’t see all my menu items (and I have to start it from the app store for it so see the ones that are listed).

When I try to compile AppEditor, it complains that “granite” is missing. The github page indicates that libgranite-dev is a dependency, but I am unable to locate the proper bundle to provide this.

Anyone have any ideas?

You can try building granite from source and see if that helps.

Good luck!


Ohhhhhhh, so that’s who makes it! May take a crack at it. Thank you! :smile:

Compiled without complaining about anything but alacarte still won’t run. Oh well. Win some lose some. :sweat_smile:

It says to run granite-demo at the end to verify it works. Were you able to try that?

Yep. That runs well. :+1:

OK so wasn’t awake yet. Zombie behind the keyboard here!

I don’t know why I tried going into my “alacarte” source directory instead of the “appeditor” source directory. :roll_eyes:

Sorry about that.

appeditor runs well enough now. Some artifacts/tearing appear on the top window bar but It’s not a big issue for me (most likely my theme is responsible). It gets the job done of removing, organizing, and adding apps to my menu. Once it’s how I like it, I probably won’t run it until I need to add another app.

Thank you!


Glad this worked out for you! Best of luck to you in the future!