33740 killing desktop

My VM and laptop received 33740 today and now i am getting this at power on:

Switched to console, logged in, did startx , got basic gnome working. Seems like its too much for me at this point…

1 Like

Same issue here.

journalctl -f 

only shows

nuc cbc_lifecycle[480]: waiting for /dev/cbc-lifecycle

twice per second

1 Like

Same issue. I feel better. I thought I had broke it. Relieved it wasn’t me!

Gnome update from 3.36 to 3.38 in 33730 could be the broken build. I guess only.

  • Go to another tty
  • Log in
  • Executed swupd repair -V 33720 --force --picky command and restored to 33720 which was working normally.

Thank you, hsendar, for your post,

the same sitaution after update,
reapair to previous 33720 version work.
You save my day!

1 Like

Same issue.
journalctl -f sent back :

NetworkManager[378]: ((shared/nm-glib-aux/nm-time-utils.c:263)): assertion ‘’ failed

Thank you Hsehdar
You same my day too !!

1 Like


Excitedly upgraded to see Gnome 3.38 and sadly reverted.

@ahkok As day progresses would there be fixed builds?

Same issue after upgrade to 33740

It’s not likely there will be a release right away, and no changes will go out until the next release.

It looks like they will be testing builds with another version of glibc over the next day or two to prepare a fix for the next release.

So, since I am running CL as a dual-boot with Win10Pro, Win10Pro first, at the end of the day, does this mean I will have to do a clean reinstall, or is there some other way to fix my installation? From what I’m seeing, a reinstall will be necessary. Is there another way?

Same this happened to when I tried nvidia drivers but got fucked thanks for the fix btw

I followed these instruction. Use control+alt+f5 (or another f-key) to access command prompt (tty). Thanks!

Be careful , swupd repair is damaged my vmware workstation installation and it wasnt so easy to repair. Seems like some python libs installed with sudo was wiped too.

Yep, this happens.
So I suggest everyone to install pyenv

1 Like

as @doct0rHu suggested or

sudo swupd repair [options] --picky --picky-whitelist=/usr/lib/python