39970 won't boot

Kernel problem. Older kernel version boots. Computer gets stuck at the blinking cursor on a black screen and virtual consoles are unavailable.

Update: this can be described as a boot hang. The boot messages say that a new USB device is found, then it hangs for a little less than a minute, then finally boots. Older kernels don’t do this.

1 Like

Yep, I get that too. Do you have any USB attachments? Have you tried booting without them?

Tried that (except the USB wireless dongle for my keyboard and mouse). Still a hang.

Arjan made a change that should show up in the next release - hopefully that will help
Cannot boot the native 6.5.3 kernel · Issue #2957 · clearlinux/distribution (github.com)

Hmmm, if that blinking cursor pause during boot-up was supposed to go away with 39980, it hasn’t. At least not for me.

This is what happened with me. I am back on LTS current and planning to stick with it. Only recently realised that playing with the ‘latest and greatest’ in the Linux world is like beta testing. :laughing:

Did you see this?


CL version 40010 / kernel 6.5.5-1366.native (64-bit) fixes the problem

1 Like

Not with /etc/environment.d/10-cf.conf from Clear Fraction still in place.

1 Like

@Tidda Sounds like Adding CF repo renders computer unbootable · Issue #34 · clearfraction/distribution (github.com) may address this now? (nice work @paulcarroty !)

Indeed, the new config file works for me.

1 Like