Anyone get the nvidia drivers working?

Hello. I realize since a recent clear linux update, installing nvidia drivers for my rtx 2080 seems to not work… I’ve tried disabling the Nouveau drivers in terminal already but when i go to do the install of drivers i get this:

nvidia-installer log file ‘/var/log/nvidia-installer.log’
creation time: Fri Jun 5 12:03:44 2020
installer version: 440.82

PATH: /usr/bin/haswell:/usr/local/bin:/usr/bin:/opt/3rd-party/bin

nvidia-installer command line:

  • ./nvidia-installer*
  • –utility-prefix=/opt/nvidia*
  • –opengl-prefix=/opt/nvidia*
  • –compat32-prefix=/opt/nvidia*
  • –compat32-libdir=lib32*
  • –x-prefix=/opt/nvidia*
  • –x-module-path=/opt/nvidia/lib64/xorg/modules*
  • –x-library-path=/opt/nvidia/lib64*
  • –x-sysconfig-path=/etc/X11/xorg.conf.d*
  • –documentation-prefix=/opt/nvidia*
  • –application-profile-path=/etc/nvidia/nvidia-application-profiles-rc.d*
  • –no-precompiled-interface*
  • –no-nvidia-modprobe*
  • –no-distro-scripts*
  • –force-libglx-indirect*
  • –glvnd-egl-config-path=/etc/glvnd/egl_vendor.d*
  • –egl-external-platform-config-path=/etc/egl/egl_external_platform.d*
  • –dkms*
  • –silent*

Using built-in stream user interface
-> Detected 8 CPUs online; setting concurrency level to 8.
WARNING: Unable to determine the default library path. The path /opt/nvidia/lib will be used, but this path was not detected in the ldconfig(8) cache, and no directory exists at this path, so it is likely that libraries installed there will not be found by the loader.
WARNING: Unable to determine the default X library path. The path /opt/nvidia/lib will be used, but this path was not detected in the ldconfig(8) cache, and no directory exists at this path, so it is likely that libraries installed there will not be found by the loader.
-> Installing NVIDIA driver version 440.82.
ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding. Please consult the NVIDIA driver README and your Linux distribution’s documentation for details on how to correctly disable the Nouveau kernel driver.
-> For some distributions, Nouveau can be disabled by adding a file in the modprobe configuration directory. Would you like nvidia-installer to attempt to create this modprobe file for you? (Answer: No)
ERROR: Installation has failed. Please see the file ‘/var/log/nvidia-installer.log’ for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

1 Like

CL does not look like it has support for optimus. Did you manage to get this working?

yes, it is working now. you can use the bash scripts and it might work with some tweaks in the script. you will require to install beta version of 450.51, nvidia has solved few issues.

I’m really glad to know this. What tweaks do you use?

hey @doct0rHu, nothing much, it was giving me error and I searched in other forums and find out that adding directory path for my kernel during advanced setup options of NVIDIA, it somehow manages to create directory and resolve that error.

1 Like

hey @lf_araujo I am not sure if Optimus is working well, I was not even able to get nvidia drivers working with my installation. I can not confirm on Optimus actually, but battery time changes based on the usage. but its not well efficient compared to windows time. With intel drivers, it was really good :slight_smile:

1 Like

Do you mind sharing the tweaks you applied to the scripts?

EDIT: And could you please run: nvidia-sni on your system?